WordPress.org

Support

Support » Plugins and Hacks » MimeTypes Link Icons » [Resolved] Problem with Images

[Resolved] Problem with Images

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor jrf

    @jrf

    Yup, makes sense. Simplest way to do this would probably be adding a filter to the_content with a prio higher than 10 to remove the mime-type icons for image links.

    Plugin Author eagerterrier

    @eagerterrier

    @thilol – you can try using the hidden_classname field in plugin admin.

    Let us know how you get on. We can always use a jquery wildcard selector instead of classname in a later version of the plugin, so

    jQuery(this).parents(‘.myexcludedclassname’).length)

    becomes

    jQuery(this).parents(‘[class^=wp-image-]’).length /* matches all images on my theme */

    My image in the post has the following css-class:

    alignleft size-full wp-image-351

    So it’s not easy to decide for one.

    Even if I use “alignleft” in the plug-in options it doesn’t work.

    This is the page: http://s4000.heubisch.eu/

    Plugin Author eagerterrier

    @eagerterrier

    @thilol – you can choose to change your hidden_classname to size-full or add the hidden_classname as a class of your image.

    I think that going forwards we will have a wildcard selector, but for the moment those are your options.

    Plugin Contributor jrf

    @jrf

    @thilol, in the new version (v3) you can add several classes to the exclude list. Hopefully this will give you more of the flexibility you are looking for.
    Also, have a look at the example I’ve added to the FAQ.

    If this is to your satisfaction, please mark the topic resolved.

    Thanks, Juliette

    Perfect!

    Plugin Author eagerterrier

    @eagerterrier

    @thilol woohoo!

    thanks @jrf for the fix.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Problem with Images’ is closed to new replies.
Skip to toolbar