WordPress.org

Ready to get started?Download WordPress

Forums

Problem with image links when changing permalink settings (8 posts)

  1. thelostswede
    Member
    Posted 4 years ago #

    Ok, some background information first.
    I've imported my Joomla site into WordPress as frankly, I've had enough of Joomla.
    Everything went as smooth as one could hope for, but I've now run into a problem that I can't figure out how to solve.
    My images are located in /images/stories/year/month/ and this works just fine as long as I stick with the default WordPress permalink structure.
    However, as soon as I try to change that, all the images on every single post beyond the first page stops working as WordPress messes with the link structure when you change the permalink structure to day and name instead of the default setting.
    Is there any way I can get this to work without manually having to redo all the images in some 180 posts?

    Cheers

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Did you upload the images via WordPress?

  3. thelostswede
    Member
    Posted 4 years ago #

    No, as I said, I imported a Joomla site into WordPress, but the images works with the default permalink structure, but as soon as I change it to something else, images on every page beyond the first page break.

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    I've not imported from Joomla but it could be that the images have not been properly entered into the database as post/pages attachments. Have you tried uploading an image via WP and seeing if that's affected by a custom permalink structure?

  5. thelostswede
    Member
    Posted 4 years ago #

    Not yet, still working out some kinks so haven't had time to do a new post yet. I'm sure you're right though, but how do I get around that problem?

  6. esmi
    Forum Moderator
    Posted 4 years ago #

    Unfortunately, by re-uploading all of the images via the WP interface.

  7. thelostswede
    Member
    Posted 4 years ago #

    Ugh, that's not going to happen, hopefully there's another solution at hand, fingers crossed.

  8. thelostswede
    Member
    Posted 4 years ago #

    Gah, I've tried everything and then some, anyone got some ideas here? :(

Topic Closed

This topic has been closed to new replies.

About this Topic