WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Problem with Image captions after 3.7 upgrade

[Resolved] Problem with Image captions after 3.7 upgrade

  • Hi

    I upgraded to V3.7 yesterday and I have discovered that in the WordPress editor any images that use the WordPress caption facility take up the whole of the page width and more.

    They display fine on my site, but it makes editing difficult.

    When I remove the caption everything is OK as it was with previous WordPress version.

    This applies to images in the WordPress media gallery and the Nextgen gallery.

    Help please!

    Stpehn

Viewing 15 replies - 16 through 30 (of 89 total)
  • Browser: Chrome (Mac)
    Full-size: No
    Caption width wrong: 1 and 2. 3 is ok, but then after I save and the page reloads or I switch between the text and visual editor then the width gets messed up.

    Chrome Mac Version 30.0.1599.101

    Insert image without caption is good.
    Insert image with caption results in the issue.

    Does not matter what size I pick or if I upload a new image or choose one from the gallery.

    Testing safari and FF mac shortly…

    Ok, same issue on Firefox Mac and Safari Mac.

    We are having the same issue in our installation. I thought it might be our theme but seems to be a core bug.

    We upgraded on multiple servers running more than 100 WordPress installations overnight. Every install is reporting the same problems with images. Looks like a bug that needs immediate attention.

    Moderator Andrew Ozz

    @azaozz

    WordPress Dev

    Thanks, that helps a lot.

    Another question: does it fix the caption width if you edit the image (from the button that is shown on clicking on the image) and just click “Update” without changing anything?

    WPyogi

    @wpyogi

    Forum Moderator

    I can’t see the problem image/caption at all in the visual editor.

    If you’re referring to the edit button, it’s 10,000 pixels to the left of the editor window I presume.

    I can fix it by editing the raw html (style=”width: 10,225px;”) in the editor.

    It goes away in you click on the “edit” button and set on 100 percent and then “update.” But when you update the post the problem returns. There is a bug somewhere.

    I went into a post and took out the caption on an image and the problem goes away. It is definitely related to the caption property.

    Same problem here …

    @mawosch, Then work through the suggestions given in this thread.

    Moderator Andrew Ozz

    @azaozz

    WordPress Dev

    Think I found it. It is an error made by the JS minifier in wp-content/js/tinymce/plugins/wpeditimage/editor_plugin.js.

    A workaround for now is to scroll until you see the image, click on it, click on the Edit Image button that shows, then click “Update” (no need to change any settings). That would reset the caption width.

    Another option is to add the following to your wp-config.php file:

    define('SCRIPT_DEBUG', true);

    This will load all JS files separately and make the admin run a bit slower, but fixes the captions error as the non-minified file is used.

    I cannot scroll until the image appears. There’s no horizontal scroll.

    Any ETA on this fix?

    WPyogi

    @wpyogi

    Forum Moderator

    They are working on it – see Andrew’s post above for a temporary work-around.

Viewing 15 replies - 16 through 30 (of 89 total)
  • The topic ‘[Resolved] Problem with Image captions after 3.7 upgrade’ is closed to new replies.