Support » Plugin: Polylang » Problem with https:// and Polylang?

  • Pippi_60

    (@gabriellabo)


    Hi,

    I am trying Polylang on a customer site and it seems to be a conflict with https:// and the Polylang plugin.

    My Swedish start page will not show up as a start page when I write my domain name (domainname.se) in the browser, it changes automately to the English version instead, even if I have put the Swedish to be the start page.

    If I write https://www.domainname.se it works just fine.

    Is this a common problem? Can you please give me an advice how I can fix it?

    Kind regards,
    Gabriella

Viewing 9 replies - 1 through 9 (of 9 total)
  • lachender_engel

    (@lachender_engel)

    This problem comes from a wrong rewrite rule http to https. Maybe it is a server configuration or the WordPress configuration or some plugins.
    Best to test is, switch to a default theme, deactivate all other plugins and check if the issue is still there. If so, you should investigate at your server configuration. If the error isn’t coming up again, you have to find out if the theme or a plugin is responsible for this issue.

    Plugin Author Chouby

    (@chouby)

    Hi,

    To avoid any SSL misconfiguration, I recommend using Really Simple SSL. I never had any issue with or without Polylang with this plugin.

    Hi
    Only one note, Really Simple SSL is a great plugin, but in the first installation in a webpage with Polylang, the page crashed, after enabling Really Simple SSL, you should save the previous adjusments made while installing polylang one more time. The webpage will load again 🙂

    Hi,
    I encounter the same issue with Polylang as Plugin after having changed to Really Simple SSL / Ssl in general. I can’t change to a default theme as I am using Conference Pro from Showthemes.

    If I deactivate Polylang, the website works perfectly fine, if activated, website is not reachable anymore due to too many loops.

    Anyone an idea resp. solution for it?

    After activating SSL on a website with Polylang I also ran into a browser loop error.

    After trying a couple of recommendations, i.e. deactivating plugins, reverting back to non-SSL, which did not help. I found I needed to re-assign the homepage in Settings – Reading and everything works fine again.

    Thanks so much @dbriedel
    Your advise did the trick for me. I had to re-assign the homepage like you suggested. No plugins necessary

    Thank you dbriedel!! You saved my day

    The best solutions are always simple 🙂

    Hi, i have the same problem but i don’t get what you are saying. Where must I the homepage re-assign ?

    Hallo, having the same problem.
    The site was working properly (http).
    Then applied the ssl dv certificate and polylang created a lot of issues (internal server error, and other bugs).
    I had to deactivate all plugins via FTP and then I could enter into wp-admin … tested all and saw that it is Polylang in new https configuration.
    Since I already lost three days I have the idea to cancel ALL and fully reinstall the website BUT …
    am I sure that starting from fresh installation with already installed ssl dv cert it works?
    It is because to remake all I will lose ten days, and want to avoid to do all again for nothing.
    Thank you. Mauro

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Problem with https:// and Polylang?’ is closed to new replies.