Support » Fixing WordPress » Problem with .htaccess (404 error)

  • WordPress’s .htaccess file is blocking Oxwall software.
    It worked fine but suddenly it stopped and all I can see is 404 error message. When I rename/delete .htaccess file, it works again.

    Hope you can help…

    Many Thanks John

Viewing 4 replies - 1 through 4 (of 4 total)
  • Is there anything non-standard in your .htaccess file?

    (custom Deny rules, odd permalink settings, mobile detection, caching etc)

    no, I don’t think so..

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Does Oxwall have any .htaccess requirements or instructions for running parallel to WordPress?

    You might need to run WP and Oxwall on separate subdomains if you can’t resolve the conflict.

    Here is oxwall’s htaccess:

    Options +FollowSymLinks
    RewriteEngine On

    AddEncoding gzip .gz
    AddEncoding gzip .gzip
    <FilesMatch “\.(js.gz|js.gzip)$”>
    ForceType text/javascript
    </FilesMatch>
    <FilesMatch “\.(css.gz|css.gzip)$”>
    ForceType text/css
    </FilesMatch>

    RewriteCond %{REQUEST_URI} .*/http-bind
    RewriteRule (.*) /http-bind [L]

    RewriteCond %{REQUEST_URI} !^/index\.php
    RewriteCond %{REQUEST_URI} !/ow_updates/index\.php
    RewriteCond %{REQUEST_URI} !/ow_updates/
    RewriteCond %{REQUEST_URI} !/ow_cron/run\.php
    RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.xml|\.feed|robots\.txt|\.raw|/[^.]*)$ [NC]
    RewriteRule (.*) index.php

    I hope to find someone who will be able to help me..
    If everything worked fine before, I think it is possible to fixt it, but how…?

    [No bumping. If it’s that urgent, consider hiring someone.]

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Problem with .htaccess (404 error)’ is closed to new replies.