[resolved] Problem with header image in twenty ten child theme (6 posts)

  1. preitybansal
    Posted 3 years ago #

    Hi all,

    I was working on twenty-ten child theme and need to replace the default twenty ten header image with my new image(change in height and width).

    All went right but I am not getting how to get the site work same for all screen widths and in all browsers.

    What I mean is I have fixed the width of the image as 1260px.. But the problem is when I put it on air on some computers the image is bigger then their screen width and in some it is smaller.

    I have use the following function:

    function my_header_height($size){
    return 165;
    function my_header_width($size){
    return 1280;

    I dont know how to change CSS for this thing.
    My site url is acheiver.netne.net/p1. I guess CSS need changes in divisions wrapper, some more. Please have a look and help me to resolve this issue.

    Its very urgent. Any help will be appreciated.

    Thank You


  2. Michael
    Part-Time Forum Moderator
    Posted 3 years ago #

    without a live link to your site, nobody will be able to really comment on your issue.

    consider to work with a browser inspection tool such as Firebug to find out about what formats the header image; or ask at a css forum like http://csscreator.com/forum

    possibly have a look at the header image css of Twenty Eleven, which is responsive/flexible in size.

  3. utern
    Posted 3 years ago #

    You can try to resize or skew your picture on Paint and see if it fits the header image and then reinstall your theme again and upload your header.

  4. preitybansal
    Posted 3 years ago #


    I have provided the live link to my site..It is acheiver.netne.net/p1
    And I am using Firebug to find all the issues..
    Please have a look at the site then you may be able to get my point clearly.

    I can also provide my login details to you if you need to check the functions I have used and the stylesheet.

    Need to solve this issue as soon as possible. I request you all please help me to sort it out.

  5. Michael
    Part-Time Forum Moderator
    Posted 3 years ago #

    missed the link -
    if you post the full url with http://...., then the forum software would change it into an active link and make it more visible.

    your site has validation errors http://validator.w3.org/check?uri=http%3A%2F%2Facheiver.netne.net%2Fp1%2F&charset=%28detect+automatically%29&doctype=Inline&group=0


    some of the errors are in the header area and might effect the display.

    to change the formatting, in style.css of the child theme, try and add width:100%; height:auto; to the style of #branding img:

    #branding img {
        border-bottom: 0px solid #000000;
        border-top: 0px solid #000000;
        display: block;
        float: left;
  6. preitybansal
    Posted 3 years ago #


    Thanx a lot, a lot and a lot..

    You save me.. Really appreciate that. Thanx for being too helpful.. :)

Topic Closed

This topic has been closed to new replies.

About this Topic