Support » Theme: ResponsiveBoat » Problem with header

  • Resolved simonlodijo

    (@simonlodijo)


    I updated to the new version of wordpress (4.5) but now I’m having trouble with the header of my website. When I first upload the website, the text in the header is double (http://postimg.org/image/3lpthuo25). After I scroll the issue dissapears, but still I want to fix it.

Viewing 7 replies - 1 through 7 (of 7 total)
  • hi, I have the same problem. Tried removing all css regarding navigation, reinstalled polylang. Nothing helps :/

    My site: http://www.ameliaromanska.com/pl/

    Would be delighted with a solution!

    Hey guys,

    Any word on a fix. I just noticed the same thing happening.
    Great looking site by the way Amerom.

    @ shawnku – thanx
    re double menu: I still don’t know how to fix this but it looks like the two different menus are displayed at one time. The temporary solution is to switch off one of them using one of this css:

    .navbar-black-init {
    display: none
    }

    .navbar {
    display: none;
    }

    In one case when loading there is no menu till you start scrolling down. In the other menu is fixed but there is a logo on the bar from the very beginning.

    If you find any better solution pls let me know.

    Hello,

    The problem is in theme js file: responsive_boat_script.js which is not compatible with jquery 1.12.3 (WordPress 4.5)
    In line 141 where is:

    jQuery('#site-navigation a[href*=#]:not([href=#]), header.header a[href*=#]:not([href=#])').bind('click',function () {

    should be:

    jQuery('#site-navigation a[href*="#"]:not([href="#"]), header.header a[href*="#"]:not([href="#"])').bind('click',function () {

    As referred to this:
    read-this-first-wordpress-45-master-list

    Thank you Amerom, I had the same problem and I just used

    .navbar-black-init {
    display: none
    }

    and it worked perfect. Its my first time posting in here but you guys have been of great help for the past 6 months or so, just updated WP and the child theme I was super scared to do so but it wasn’t all that bad, just some changes to CSS and is looking the way it was. Anyways thank you guys.

    http://www.iverifyu.com

    Thank you so much @lukodp, this worked perfectly!

    I was a few days away from launching a new site, and finding this header issue so close to release was not pleasant! You saved me!

    Thank you everyone who participated in this thread!

    Hello,

    As mentioned in a previous thread:

    We just released an update to fix this issue. But if you made changes to the theme files and don’t want to update, and lose those changes you can follow this doc: http://docs.themeisle.com/article/281-how-to-fix-issues-with-wordpress-4-5-in-responsiveboat-without-updating.

    Best regards,
    Rodica

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Problem with header’ is closed to new replies.