Support » How-To and Troubleshooting » Problem with Gzip enabled

Problem with Gzip enabled

  • Excuse me if this has been addressed before, but I only found 1 post about this that was closed.

    I’m using Headwaytheme which has the option for gzip compression. If the option is activated I receive a “Error 330 (net::ERR_CONTENT_DECODING_FAILED): Unknown error.”in Chrome. A similar message in FireFox:”The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.”

Viewing 5 replies - 1 through 5 (of 5 total)
  • I believe that’s a commercial theme. If so, you’ll need to address the error with support at Headway themes. They also have their own FAQ and Codex.

    Lots of discussions regarding that error issue in the Chrome browser, as well.

    umm, deactivate the theme or rename it if you can acces to your wp-admin

    try to add gzip with W3 Total Cache or Super Cache instead, it also add expiration dates and you’ll get better overall perfomance

    Or, if you would like to try activating gzip compression on your WordPress site yourself – rather than allowing the theme or a plugin to do it – you can log in, navigate to /wp-admin/options.php and change the setting in the gzipcompression field from 0 to 1 and save the changes.

    ..and don’t rule out discussing compression settings/features with your hosts support group.

    Thank you all for the answers.
    For now I deactivated the gzip function from the Headwaythemes setup.
    I’ll take a look at W3Total Cache and the like. The current hosting provider also has available a SuperCacher from the CPanel; don’t know if its the same Super Cache that Luis mentioned. I’ll check.

    As for activating gzip on WP from /wp-admin/options.php, maybe I misunderstood but I did not find any references to ‘gzip compression’ field in options.php Should I look in other file?

    Should I look in other file?

    No. It should be on the options.php page. Log in as admin, and go back to yoursite.com/wp-admin/options.php.

    All available options are listed alphabetically from the top of the page to the bottom. You should see this in the list:

    gzipcompression [ 0 ]

    If you can’t locate it by scrolling, hit Ctrl+F and enter gzipcompression in your browsers page search function. That should highlight it for you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Problem with Gzip enabled’ is closed to new replies.