Support » Plugin: Affiliates Manager » Problem with Google Recaptcha

  • Resolved sirebral

    (@sirebral)


    Seems there’s may be a file_get_contents in the Google Recaptcha code that’s causing it to fail on my hosting. I’ve run into this before and resolve it by putting in a CURL rather than using the file_get_contents call. The symptom is that Recaptcha is unable to connect when trying to verify the Captcha. It doesn’t error out, rather it fails silently and presents the registration page again.

    Here are the error entries in the hosting logs:

    2019-05-15 23:57:37	Warning	50.39.126.19		1583#0: *27822 FastCGI sent in stderr: "PHP message: PHP Warning: file_get_contents(): SSL: Handshake timed out in /var/www/vhosts/juicedflavors.com/staging.juicedflavors.com/wp-content/plugins/affiliates-manager-google-recaptcha-integration/lib/ReCaptcha/RequestMethod/Post.php on line 68PHP message: PHP Warni" while reading upstream				nginx error
    2019-05-15 23:57:37	Warning	50.39.126.19		1583#0: *27822 FastCGI sent in stderr: "ng: file_get_contents(): Failed to enable crypto in /var/www/vhosts/juicedflavors.com/staging.juicedflavors.com/wp-content/plugins/affiliates-manager-google-recaptcha-integration/lib/ReCaptcha/RequestMethod/Post.php on line 68PHP message: PHP Warning: file_get_contents(https://www.google.com/recaptcha/api/siteverify): failed to open stream: operation failed in /var/www/vhosts/juicedflavors.com/staging.juicedflavors.com/wp-content/plugins/affiliates-manager-google-recaptcha-integration/lib/ReCaptcha/RequestMethod/Post.php on line 68PHP message: PHP Warning: file_get_contents(): SSL: Handshake timed out in /var/www/vhosts/juicedflavors.com/staging.juicedflavors.com/wp-content/plugins/affiliates-manager-google-recaptcha-integration/lib/ReCaptcha/RequestMethod/Post.php on line 68PHP message: PHP Warning: file_get_contents(): Failed to enable crypto in /var/www/vhosts/juicedflavors.com/staging.juicedflavors.com/wp-content/plugins/affiliates-manager-google-recaptcha-integration/lib/ReCaptcha/RequestMethod/Post.php on line 68PHP message: PHP Warning: file_get_contents(https://www.google.com/recaptcha/api/siteverify): failed to open stream: operation failed in /var/www/vhosts/juicedflavors.com/staging.juicedflavors.com/wp-content/plugins/affiliates-manager-google-recaptcha-integration/lib/ReCaptcha/RequestMethod/Post.php on line 68" while reading upstream

    And here’s a link to a discussion about this issue:

    https://stackoverflow.com/questions/14078182/openssl-file-get-contents-failed-to-enable-crypto

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support mbrsolution

    (@mbrsolution)

    Hi, thank you for reaching out to us and reporting this issue. The plugin developers will investigate further your findings.

    Kind regards

    Plugin Author affmngr

    (@affmngr)

    @sirebral, This is coming from the official Google reCAPTCHA library. Affiliates Manager uses it to add reCAPTCHA to the registration page.

    We have just updated the library to the latest version. Can you please update our reCAPTCHA addon and test it?

    Hi I am also having problems with the recaptcha.
    When a user logs by the affiate login he is redirected to standard wordpress login page. the error says:

    Authentication failed.
    You have entered an incorrect reCAPTCHA value.

    I am using recaptcha V3.
    I have installed latest affiliate manger plus latest addon “Affiliates Manager and Google reCAPTCHA Integration”

    Plugin Author affmngr

    (@affmngr)

    @hellenx, Our registration forms supports reCAPTCHA v2. Please give it a try with your reCAPTCHA v2 credentials and see how it goes.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Problem with Google Recaptcha’ is closed to new replies.