Support » Plugin: Q2W3 Fixed Widget for WordPress » Problem with Genesis Framework

  • When i use your plugin to sticky one widget, the widget, when we scroll the page, comes out of the page.

    Please could you fix this?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor Max Bond

    (@max-bond)

    The plugin computes and sets style parameters for selected widgets. That’s all! Sometimes theme layout is not compatible with fixed positioned elements in general. That’s the problem of the theme, not the plugin! Sometimes it could be fixed, sometimes not. I can take a look, but it is not 5 minutes work and this kind of work should be paid for.

    I’ve been using this plugin for months and loving it. It always worked perfect. BUT it stopped working with the latest update.

    I’m also on the Genesis framework, as are many, many, many other WordPress sites.

    Both Genesis and Q2W3 were recently updated. Not sure what’s going on but seems like it’s related to the updates.

    Plugin Contributor Max Bond

    (@max-bond)

    Stopped working?

    Check for javascript errors first!

    If you have cache plugins installed, clear the cache!!

    we are using w3tc and cloudflare , we are celared all the cache, and all plugins working fine except this, could you suggest some fix for this issue?

    sorry cleared the cache, we are using also autoptmize

    Plugin Contributor Max Bond

    (@max-bond)

    Micheleficara, is it ok now?

    Same problem here with the genesis framework.

    I had to download the version 5.0 of the plugin to work, if anyone need this version u can download here: https://downloads.wordpress.org/plugin/q2w3-fixed-widget.5.0.zip.

    Since the latest update this plugin is not working with genesis framework.

    From the chrome console there is this error:
    – Uncaught TypeError: b.target.className.indexOf is not a function

    But using version 5.0 of this plugin works fine with genesis framework.

    Cheers.

    max, no

    cassianotartari

    (@cassianotartari)

    Same error here using Braxton theme “Uncaught TypeError: a.target.className.indexOf is not a function” Disabled minify plugin and keep not working

    Hi,

    Same error here with genesis:

    Uncaught TypeError: a.target.className.indexOf is not a function
    q2w3-fixed-widget.min.js:1

    But it works for me…

    Since the last update “5.0.3” the plugin works on Genesis Framework, but still show the error mentioned before.

    Just to let the author aware.
    Cheers.

    same error for me too. not using the genesis theme

    Uncaught TypeError: a.target.className.indexOf is not a function
    at https://www.(site).com/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.0.4:1:606
    at Array.forEach (native)
    at MutationObserver.<anonymous> (https://www.(site).com/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.0.4:1:490)

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Problem with Genesis Framework’ is closed to new replies.