Support » Plugin: Booster for WooCommerce » Problem with Gateways Fees and Discounts for unregistered customers

  • Resolved effgee

    (@andreastyrosvoutis)


    Gateways Fees and Discounts are not applying properly unless a user is already logged in.

    It seems that the anonymous guests don’t get the fees applied, even when creating an account during their initial order.

    What is odd, is as a guest user, when going to the checkout page, on initial load of the page, the fee is shown momentarily but then disappears after the page completely loads..

    Would really appreciate a bit of help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author ronyp

    (@ronyp)

    Hello,

    Can you please let me know which are the add-ons from the plugin are active at the moment? Are you using any user role-related add-on from the booster?
    Can you kindly please send me some screenshots of the configuration you have set?

    Kind Regards,
    Rony P – Support Team

    Thread Starter effgee

    (@andreastyrosvoutis)

    Hi,

    This exact same problem is occurring on two separate plugins for modifications of fees
    Booster & Payment Gateway Based Fees and Discounts for WooCommerce

    I don’t run them simultaneously, just the exact same behavior occurs. Fee appears momentarily during checkout, something ajaxy happens and the fee disappears.

    Fee appears properly for logged in users.

    As far as enabled Booster features, only:
    Gateways Fees and Discounts
    PDF Invoicing
    Αναφορές (Which I think is Reports, Booster incorrectly displays the wrong languages for certain settings & feature names even though my admin is set to English) – Stock, sales, customers etc. reports.

    In Gateways Fees and Discounts
    It is enabled only for Cash on Delivery Method.

    I have sent links to the screenshots and a video link to the behavior to the contact form on your main site due to some privacy concerns here: https://booster.io/contact-us/

    I can send directly to email if I had one.

    • This reply was modified 6 months, 1 week ago by effgee.
    Plugin Author ronyp

    (@ronyp)

    Hello,

    We are unable to replicate the issue you have mentioned at our side.
    Can you please give some basic idea of your setup with which I can replicate the issue?

    Kind Regards,
    Rony P – Support Team

    Plugin Author ronyp

    (@ronyp)

    Hello,

    The ticket is closing after a period of inactivity.

    Kind Regards,
    Rony P – Support Team

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.