WordPress.org

Support

Support » Installation » Problem with Feed and Permalinks

Problem with Feed and Permalinks

  • I’m trying to create a feed with FeedBurner (using the FeedBurner Feed Replacement plug-in) and it doesn’t seem to recognize the feed I enter (http://MYDOMAIN.com/blog/?feed=rss2). I checked to see if another feed reader would recognize it and it doesn’t.

    Also — when I tried to customize the permalinks structure to date and name based, I get an error message that tells me to update my .htaccess file. My understanding is that this update is supposed to happen automatically, but WordPress writes nothing to this file. I checked my permissions and it has write access.

    Not sure if these problems are related. Any ideas?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Also — when I tried to customize the permalinks structure to date and name based, I get an error message that tells me to update my .htaccess file. My understanding is that this update is supposed to happen automatically,[…]

    If WP tells you to add stuff to .htaccess, that’s because the file permissions on it were such that it couldn’t be done automatically.

    So, in that situation, you need to copy/paste what’s provided on Options -> Permalinks and add it to .htaccess manually.

    mrsmecomber

    @mrsmecomber

    I am having the same problem with RSS Feed as patricer who had said:


    I’m trying to create a feed with FeedBurner (using the FeedBurner Feed Replacement plug-in) and it doesn’t seem to recognize the feed I enter (http://MYDOMAIN.com/blog/?feed=rss2). I checked to see if another feed reader would recognize it and it doesn’t.

    Now for me, when I go to my blog’s sidebar Meta widget and click on “Comments RSS” it works fine. When I try “Entries RSS” or when I click on the RSS icon in the browser address bar, I get this page that says:

    HTTP Status 400-You must provide a feed uri
    type Status report

    message You must provide a feed uri

    description The request sent by the client was syntactically incorrect (You must provide a feed uri).

    I have the FeedSmith plugin, I have the proper FeedBurner url (it works with other things). But those two links (the “Entries RSS” and the RSS icon in the browser address bar) do not work.

    I recently changed my own .htaccess file so I could have my post-name in my permalinks. I do not know if this is related.

    I am using the recent WP version. My blog is http://www.newyorktraveler.net

    Things I have tried so far and haven’t worked:

  • deactivating FeedSmith
  • entering in a different feed url ( http://newyorktraveler.net/?feed=rss2 and http://feeds.feedburner.com/NewYorkTravelernet?format=xml)
  • deactivating my Slashdiggalicious plugin
  • changing permalinks to show category/postname instead of just postname
  • Nothing has worked yet. I’d sure like help with this. Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Problem with Feed and Permalinks’ is closed to new replies.
Skip to toolbar