WordPress.org

Forums

[resolved] Problem with Featured Image & Media Library (4 posts)

  1. IslandOwl
    Member
    Posted 2 years ago #

    Can someone please help me rectify a glitch in my Media Library that is effecting the Featured Image selection?

    This has been going on a while and is theme independent.

    When I click on Set Featured Image on my post page it opens my Media Library and I can "select" an image but then, when I click on the Set Featured Image below the selected image (over on the right side bar part of the media library) a duplicate of the image pops up over on the left in the media library. I go back to the post and the featured image does not show up. Setting the featured image did not take. The same thing keeps happening if I try to do it again. I can end up with what looks like multiple duplicates of the image in the media library.

    However when I go to the dashboard and open the Media Library, the "images" that were created are actually blanks - no image - and attached to nothing.

    In trying to figure out the problem I installed the Drag & Drop Featured Image (which is a nice plugin!). The plug in will work and put in a featured image if I drag and drop it from my computer but it too will not work if I select something from my Media Library. Note: the plugin works fine. The problem is with my Media Library.

  2. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Have you tried reinstalling WordPress manually from a freshly downloaded copy except wp-contents. Make sure that you delete all old files before uploading fresh ones.
    Also, try to deactivate all plugins and see if it helps.

  3. IslandOwl
    Member
    Posted 2 years ago #

    Oddly enough it finally seems to be repaired all by itself. At lease it is working well now with the Drag & Drop Featured Image. So I am a happy camper.

    Maybe all I needed to do was to write in here and it scared my WP into working. It is so odd because it really has not been working for quite a while!!

  4. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    It happens sometimes, weird things first and unexpected results later that cannot be easily explained.

    Glad to hear that your site works fine! :)

Topic Closed

This topic has been closed to new replies.

About this Topic