Support » Plugin: WP Native Articles - Facebook Instant Articles Plugin for WordPress » Problem with embedding youtube video

  • Resolved shivrajansingh

    (@shivrajansingh)



    When you embed youtube or instagram video this plugin doesn’t include “</iframe>” (closing iframe tag) on the rss feed here is the sample code when you embed youtube video
    <figure class="op-interactive"><iframe src="https://www.youtube.com/embed/XWIDLmhbmeA" width="300" height="250" frameborder="0" allowfullscreen="allowfullscreen"/></figure>

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author OzTheGreat

    (@ozthegreat)

    Hi,

    Thanks for getting in touch. Humm I see, how are you adding the YouTube video to your post in WordPress? Are you using that code or something else? If you just paste in the URL to the YouTube video into the post editor then it should convert correctly.

    Also, what version of the Content Parser are you using (second option down on the General Settings tab)?

    Thanks

    thanks for ypur reply ..
    actually I am adding simple iframe tag to my wordpress post ..the code you are seeing above is the output of the rss feed.
    here is the iframe code which is post in my wordpress post
    <iframe src="https://www.youtube.com/embed/XWIDLmhbmeA" width="300" height="250" frameborder="0" allowfullscreen="allowfullscreen"/></iframe>

    Plugin Author OzTheGreat

    (@ozthegreat)

    Hi,

    Ahh I see. I’ve just tested this and you’re absolutely right, it does self close the iframe tag. I’ve found the issue and applied a fix that will go out in the next release. If you’re comfortable editing code you can just replace line 547 of the file with /includes/class-facebook-post.php with the following:

    $dom_document->loadHTML( '<!doctype html public "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"><html xmlns="http://www.w3.org/1999/xhtml">' . $content . '</html>' );

    Alternatively, just let me know and I’ll put together a beta release of the plugin for you with the patch applied.

    Anther workaround would be not to paste the iframe code into your post. If you just paste in the URL to YouTube video then WordPress should automatically embed it and it should get converted correctly.

    All the best.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Problem with embedding youtube video’ is closed to new replies.