Support » Fixing WordPress » Problem with editing comments using WP 2.0.3

  • josalmon

    (@josalmon)


    I upgraded to WordPress 2.0.3 from 2.0.2 yesterday and it all went smoothly.

    However, I just edited a comment and apart from being met with an extremely annoying “are you sure you want to do this?” message, it’s now screwing up the edited comment – if there is an an apostrophe, then a \ is inserted before the apostrophe and if there is a link then it sticks slashes in all over the place and breaks the link, like this:

    http://example.com/year/month/post-slug/\http://example.com/\

    The link consequently breaks.

    How do I fix this?

Viewing 11 replies - 1 through 11 (of 11 total)
  • josalmon

    (@josalmon)

    Update – it’s not just commnents, I just edited a link in my blogroll and it’s stuck a back slash (or hash or whatever this is called: \ ) in the link description as well.

    NuclearMoose

    (@nuclearmoose)

    There is a fix available for this at:
    http://txfx.net/code/wordpress/wordpress-203-tuneup/

    josalmon

    (@josalmon)

    Brilliant, thanks 🙂

    manstraw

    (@manstraw)

    hmm, works properly for me. no problem with url’s or inserted backslashes. maybe a plugin conflict?

    Kowalsky

    (@kowalsky)

    Thanks for the link NuclearMoose, works fine for me now.

    spencerp

    (@spencerp)

    *EDITED I just downloaded that “plugin” and applied it. However, I’d still like to have these fixes without needing a plugin lol.. Oh well I guess..

    Just curious NuclearMoose, has this been fixed in the /branches/2.0/ since 2.0.3 was “officially released”? Usually I get all the emails from every list, but sometimes my mail accounts are screwy, not sure if I even got the notices of those file changes..

    Just was wondering if I could just download the latest branch of 2.0 or whatever, with those fixes applied. Thanks..

    spencerp

    evilzenscientist

    (@evilzenscientist)

    Any news on a rev of 2.0.3 (2.0.4 maybe) with this included?

    I’ve got a couple of sites I want to hit with this in the next week – don’t want to have another plugin I need to do security validation on.

    manstraw

    (@manstraw)

    so why is it I don’t need the plugin? I upgraded from 2.0.2 to 2.0.3. not getting the problems reported.

    That confirmation editing a comment should have a flag in the options. Does that plugin do that? Or does it just disable it?

    Moderator Mark Jaquith

    (@markjaquith)

    WordPress Lead Dev

    manstraw,

    If you’re not experiencing those problems, then you probably don’t have a proper install of WP 2.0.3

    The confirmation exists because the nonce (blog/user/action/object/time key) in the form doesn’t match the one on the receiving end. The same problem exists when you edit another WP user’s profile. Both of those are fixed in my plugin by providing versions of the nonce create/verify functions that look for these malformed keys, and correct them, so that they match. It does NOT disable any security measures! It also fixes the slashes bug by stripping the slashes where appropriate. These fixes are the same as the fixes that have gone into /branches/2.0.3/ … I just made it into a plugin form.

    No news on on when (or if) an updated version of WP will be out, sorry.

    Evilzenscientist,
    you may want to check out /branches/2.0/ from SVN. That has 3 of the 4 fixes that my plugin provides (and will likely get the 4th soon… I’ve provided the patch for it).

    manstraw

    (@manstraw)

    Just to clarify, I’m specifically referring to the backslashes when I say it doesn’t happen to me. I do get the confirmation on a comment edit. Any idea where the slashes come from in the first place?

    Brik182

    (@brik182)

    edit: (don’t mind this post) I fixed it

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Problem with editing comments using WP 2.0.3’ is closed to new replies.