Support » Plugin: SitePush » problem with dbs config file

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’m having the same problem, but with both files.

    Sites config file present, but it cannot be read.

    Plugin Author Mark Rowatt Anderson

    (@markauk)

    First, please check that you are giving the full path to the sites/dbs config files – for example:-
    /home/user/www/config/sites.ini.php

    (actual path will of course be different in your case).

    If that doesn’t work, I’ll need to know more about your setup to help.

    If you add the following line to your wp-config.php file
    define('SITEPUSH_DEBUG', true);

    (it should go anywhere above /* That’s all, stop editing! Happy blogging. */ )

    SitePush will then show a bunch of debug info on the SitePush options screen. Please post that info here, or if you prefer email it to me.

    Plugin Author Mark Rowatt Anderson

    (@markauk)

    Another thing to try – if a either config file contains a line with the tilde character (~) and possibly other ‘special’ characters it confuses PHP.

    You can either remove that character, or try enclosing that config item in quotes, for example:-

    option = "~/somevalue"

    Thank you so much! Great and timely support via email.

    I’m having this problem with a site. I think it’s being caused by the “&” character in my database password.

    Plugin Author Mark Rowatt Anderson

    (@markauk)

    Did enclosing the password in quotes work? According to PHP documentation, the following characters would need to be enclosed in quotes:-

    ?{}|&~![()^

    And if a password has a double quote it would need to be escaped, i.e. instead of my"password it would need to be my\"password

    Hi Mark, I had changed my passwords to more compatible ones before I noticed you were enclosing them in quotes and escaping them so I can’t say. Thank you for bringing us one of the best plugins ever, I only wish I had discovered it sooner. 🙂

    Plugin Author Mark Rowatt Anderson

    (@markauk)

    Glad you got it sorted, and thank you 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘problem with dbs config file’ is closed to new replies.