Support » Theme: Customizr » Problem with Customizr Theme

  • I am using Customizr Verision 3.1.6 and made a small change to the php file titled : ‘class-header-header_main.php’ after making this change the site crashing showing this error:

    ‘Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /data/24/3/137/37/3300526/user/3683555/htdocs/home/wp-content/themes/customizr/parts/class-header-header_main.php on line 299’

    This can be viewed at .

    I need to fix this immediately as this site needs to be deployed as soon as possible. I was making a last minute change to change the heading type.

    So far I have access through the ftp and deleted the ‘class-header-header_main.php’ file and reinstalled the file from customizr version 3.1.11.
    When I deleted the file I was still getting the same error and still have the same error after reinstallation.

    Please help as soon as possible.

    Thank you

Viewing 15 replies - 1 through 15 (of 17 total)
  • You’ve changed a core file, which is why we encourage you to do things in a Child Theme to avoid this.

    To get back to the core 3.1.6 file, download and extract from here. Then reapply (correct) code.


    I have downloaded the ‘class-header-header_main.php’ from the 3.1.6 file theme link you provided and replaced the one from version 3.1.11.

    I am still getting the same error as previously mentioned. Is there anything else I can do to fix this error?

    It now depends on what is your base version, 3.1.6 or 3.1.11? You can’t mix and match files from both versions.

    You need to fully install 3.1.6 or 3.1.11. My concern is that I don’t know what other changes you may have made.

    Why don’t you delete the theme and re-install it? and create a child theme and edit on top of it.

    All files are from 3.1.6. The only change I made was to ‘class-header-header_main.php’ file and uploaded the same titled file from version 3.1.11. I have since changed this file back to the version from 3.1.6 with the link you provided.

    I am still receiving an error on this particular line from that file:
    line 299
    $html = sprintf(‘<div class=”container outside”><%1$s class=”site-description”>%2$s</%1$s></div>’,

    That’s the correct medium-term strategy, Jay. I think there is some panic as the site is meant to be live this afternoon so I’ve tried to keep to a basic install without Child Theme.

    Looks like missing semi-colon at end? Sorry, this a core file so I must be wrong. Let me look and I’ll come back to you

    The error is on line 299 but here are lines 299-302:

    $html = sprintf(‘<div class=”container outside”><%1$s class=”site-description”>%2$s</%1$s></div>’,
    apply_filters( ‘tc_tagline_tag’, ‘h2’ ),
    apply_filters( ‘tc_tagline_text ‘, __( esc_attr( get_bloginfo( ‘description’ ) ) ) )

    Have you made any other customisation to any other files?

    That code above is correct

    That makes sense. Btw PHP would make funky error like this when you have empty space at the bottom or top. Try removing them all. And see the <?php ?> tags are properly completed.

    No, just the one previously mentioned.
    I am surprised that the reinstallation of this file has not fixed it.

    Could it take longer then a half hour to work?

    Can you switch to a different Theme in Appearance>Themes, then deactivate and reinstall 3.1.6 using the zip file method? Looks different in WP 3.9, so alternative is to unzip the zip file, then FTP the files to your Server, making sure you copy from/to the correct directories.

    But we’ve copied back the core file which doesn’t have trailing spaces – good suggestion though Jay!

    Final line 311 is }//end of class which is correct

    I cannot switch to a theme that i know of due to only being able to access files via FTP. I used a cleaner to make the php file have less spaces but I am still getting the same error on line 299 even tho there are not 299 lines. I will try to uninstall and reinstall the theme via FTP.

    Even with the theme deleted from the ‘themes’ folder via ftp I am still getting the same error. Is there a way to refresh this page?

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Problem with Customizr Theme’ is closed to new replies.