Support » Plugin: WP RSS Aggregator » Problem with Custom Post Types (and Polylang)

  • Resolved christianbueschi

    (@christianbueschi)


    Hi,
    I have a similar issue as others already mentioned:

    -> I get a 404 when I try to open a translated custom post type.

    It appears only when WP RSS Aggregator is activated. After deactivation the plugin and updating the permalinks, the page appears as expected.

    The problem is that the plugin always flush_rewrite_rules() if there is no registered rewrite rule for the custom feed.
    see file: includes/custom-feed.php row 53

    After deleting this function call on line 53, custom post types and translations working properly.

    Thanks for your help!

    https://wordpress.org/plugins/wp-rss-aggregator/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi,

    I tried to reproduce the issue on the latest version of our plugin ( 4.8.2 ) and Polylang ( 1.8.1 ) but I failed to re-create this scenario. Can you let me know what steps did you follow ? Maybe I did something wrong.

    Regards

    We have a “normal” WordPress Setup (no multisite), a few registered Post Types, Polylang 1.8.1 and your Plugin ( 1.8.2 ).

    The scenario is as follows: I create a new post inside a custom post type und translate it. When I open the created post in the Frontend it appears in the default language as expected. But all the translated posts end up in a 404.

    Do you have any registered rewrite rules for a custom feed? Can you check if your plugin calls flush_rewrite_rules() on line 53 in includes/custom-feed.php. If it does, you should be able to recreate the scenario.

    Thanks!

    Hi,

    Thanks. I will try to reproduce the issue on my end as per what you have mentioned. Will get back to you soon.

    Regards

    Hi,
    the problem itself is the line 32 in custom-feed.php:
    $rules = get_option( 'rewrite_rules' );

    As soon as I comment it out, I don’t get any 404 on custom post types anymore.
    When I copy this line to functions.php (for example), I get the Error 404 on CPTs again.

    Thanks for your help!

    Plugin Author markzahra

    (@markzahra)

    Hi,

    Thanks for the feedback! We’re having our developers look into it.

    Regards,

    Mark

    Hi,
    is there any progress on that issue?
    Do you need some further information?

    Thanks,
    Chris

    Hello,

    I’m having an almost identical issue with Custom Post Types, Polylang and WP RSS Aggregator. In my case, when a custom taxonomy rewrites the URL in Types, if I try to load all posts in such taxonomy and WP RSS Aggregator is active, I get a 404 error. The non-working URL looks something like this: http://our.website.edu/en/taxonomy/taxonomy-argument/

    I think these issues are related because I tried commenting out line 32 in custom-feed.php, as christianbueschi suggested, and taxonomies load fine now.

    Let us know if you need any more information regarding this issue.

    Plugin Author Xedin Unknown

    (@xedinunknown-1)

    Hi all!

    Apologies for not posting any updates for a long time. Unfortunately, we are still unable to reproduce the issue on our end. If one of you is experiencing the symptoms consistently, and is willing and able to help come up with a definitive set of steps to reproduce this, please contact us through our premium support channel.

    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Problem with Custom Post Types (and Polylang)’ is closed to new replies.