Support » Fixing WordPress » Problem with Custom Fields Data Entry

  • Resolved Joe Siegler


    I’ve got a problem with Custom Fields in my WordPress Install. At first I thought it might have been related to a theme I’m using, but I hit up the support for the theme, and we went through a ton of options, and the problem remains. First off, the problem.

    I’m having an issue entering data into the custom fields areas. Here’s what it looks like when I enter something (as I’m sure y’all all know) and it works right. I took this shot from another blog of mine that isn’t having the problem.

    OK, that’s fine. However, on the problem site/blog, when I try and do the same thing, that doesn’t happen. The data gets entered, but unlike normal, I never get that “flashing yellow” area like custom fields normally does, the newly entered field moves “up” on the screen, and then I can enter another one. I get what ends up looking like this:

    I can get around it if I enter the custom field, it displays wrong, and then I hit “save draft”, then go back to the list of posts, and re-edit. I can then enter another custom field. This is a huge pain for me, because the bulk of the entries on my site have three custom fields per entry. Due to some help from the support theme people, I’ve tried this group of steps to resolve this.

    1) First, I thought it was a conflict with some plugin on my end. So I disabled ALL my plugins, and it made no difference.

    2) Then I thought perhaps it was something in my local browser (Chrome). So I tried Firefox, IE, & Safari. Same problem. Went back to Chrome, and tried disabling my plugins in Chrome. No luck. Problem remains.

    3) Tried using the Twenty Eleven theme. No change. Not a theme problem.

    4) Made sure no dropin plugins existed (one did, I removed it), and disabled all plugins again. No change. Problem remains.

    5) Downloaded a fresh copy of WordPress (3.42, btw) and overwrote the operating copy on my server with a new one. Problem remains.

    6) Tried a website scanner, and it didn’t turn up any malware or anything like that.

    7) Installed WP DB Manager Plugin, ran both optimize & repair, no change.

    Problem remains after all of this. Everything else works with this WordPress install. It’s JUST adding custom fields data and the display in the editor screen. The data actually DOES get added, but if you need to add more than one, you have to jump through hoops to do it. The support guys for my theme theorized it’s something b0rked with Ajax or Javascript, but are at at loss to explain it.

    Anyone have any idea where to look? Thing is, this USED to work here, it only stopped working at some point in the last few months that I’m unclear of the actual date.

    Thanks for any suggestions.

Viewing 1 replies (of 1 total)
  • Somewhere along the line this got fixed, although I don’t know when.

    I’m using current code, and this doesn’t happen anymore, so it was a bug in there somewhere, and something between 3.42 & 3.51 fixed it. 🙂

Viewing 1 replies (of 1 total)
  • The topic ‘Problem with Custom Fields Data Entry’ is closed to new replies.