WordPress.org

Ready to get started?Download WordPress

Forums

Custom Community
Problem with Custom Community Child Theme (3 posts)

  1. Amelia
    Member
    Posted 2 years ago #

    I am getting the following error when I try to view the blog page.

    Warning: require(./wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in /homepages/36/d239924931/htdocs/pvcf/wp-content/themes/pvcf/index.php on line 17

    Fatal error: require() [function.require]: Failed opening required './wp-blog-header.php' (include_path='.:/usr/lib/php5') in /homepages/36/d239924931/htdocs/pvcf/wp-content/themes/pvcf/index.php on line 17

    I am using a child theme for Custom Community. I did some of the changes using the Theme Test Drive plugin. I have a static page and posts page. Everything was working fine until I enabled the posts page. Do I need to do something to the child theme to fix this? Help! :-)
    Amelia

  2. Full Circle
    Member
    Posted 2 years ago #

    Not sure what you did to break this.
    What changes did you make to the posts page?

  3. Amelia
    Member
    Posted 2 years ago #

    I have no clue what I did... I only know enough to be dangerous, lol! I tried just replacing the child theme and starting over, but it still didn't work. I ended up just uploading the theme again, as well as the child theme. Thankfully, my pages and the photos, etc, were all still there, except the widgets, which I haven't done much with anyway. When I enabled the post page, it worked fine after that.
    One thing I noticed is that this theme writes to the child theme's style sheet once you enable the child theme. Is that theme related, or is that something new with WP? My child theme style sheet was only the very basic lines described in WordPress's instructions on creating a child theme. I haven't done any modifications to the CSS yet...
    Thanks for your response :-)
    Amelia

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic