Support » Plugin: Wordfence Security - Firewall & Malware Scan » Problem with configuration

  • Dear all.

    I have latest WP, latest PHP, the settings of the server is Apache + CGI/FastCGI and there still appears the Wordfence Live Activity:Idle and Firewall Protection Level: Basic WordPress Protection.

    I went through the configuration as recommended in wordpress dashboard (clicked all recommended buttons and backed up all files and there still appears message “To make your site as secure as possible, take a moment to optimize the Wordfence Web Application Firewall:…”

    What to do next?

    I did not find the file /system/www/patches/environment.php in the wp site folder (I always click include) and where is the php.ini file?

    Thanks for your help.

Viewing 6 replies - 16 through 21 (of 21 total)
  • Hi @wfyann,

    I have contacted the support and send them the information. They do not understand exactly what does it mean. Could you please be more specific?

    They have asked me:
    “The application talks for example about an auto_prepend_file directive. Do you try to set this one or any other one?”

    Thank you.

    • This reply was modified 3 years, 6 months ago by happik.

    Dear @wfyann,

    I have just received an explanation from support.
    They can’t change the “prepend_file” setting because it is already set within php.ini. It is used for server variables.

    They didn’t received any other requests of this kind from anyone else but they will take it into account in next update.

    Do we have any other possibility?

    Thank you, Karel

    • This reply was modified 3 years, 6 months ago by happik.

    Hello @happik,

    Unfortunately, unless your hosting provider allows you to set your own value for the auto_prepend_file directive, you won’t be able to optimize the Firewall, however it will still provide a Basic WordPress Protection.

    Dear @wfyann.

    Do you think that the ptotection that I have now is sufficient to not being hacked? Should I consider to install additional firewall protection unless the provider allows me to change the value? Vhich protection is suitable for me now?

    Thank you for your time.

    I worked with my server to resolve the auto_prepend configuration settings, but the “configuration is incomplete” message continues to appear.

    For what it’s worth, this fellow found that the problem disappeared when he changed hosting services:
    https://wordpress.org/support/topic/wordfence-application-firewall-configuration/

    I like my provider, and don’t want to move away from them. I’ve sent the issue to them, and plan to post a follow-up with the resolution, if they figure it out.

    Meanwhile, the question is: How unprotected am I, if WordFence says that it is running, if the auto-prepend is configured, but WordFence still says the configuration is incomplete?

    One more message to make sure I’m notified of replies…

Viewing 6 replies - 16 through 21 (of 21 total)
  • The topic ‘Problem with configuration’ is closed to new replies.