WordPress.org

Support

Support » How-To and Troubleshooting » Problem With Comments on My Blog

Problem With Comments on My Blog

  • Hello again everyone,

    One of my viewers just emailed to let me know that he was unable to leave a comment on my blog. I tried clicking on the comment line and keep getting the following error message:

    404 Not Found
    The Requested URL Was Not Found on This Server
    Apache Server at theurbangrindblog.com

    So if anyone knows how to fix this, I’m all ears.

    Thank you very much!
    Lisa

Viewing 15 replies - 1 through 15 (of 30 total)
  • A link would be helpful so we could investigate further.

    http://theurbangrindblog.com

    You’ve set up a custom permalink structure, but do you have a .htaccess file set up for it, as well? Look at the information on setting up custom permalinks:

    http://codex.wordpress.org/Using_Permalinks

    This all started when I tried adding Permalinks. I got an error message saying I should update my .htaccess. I realize that’s a hidden file, and I have not been able to open it with my Cute FTP client. I don’t see any option of “hidden files.” So if anyone can let me know how to access my .htaccess file, that would be great.

    Thanks.

    Provided this in reply to another thread of yours:

    http://codex.wordpress.org/Changing_File_Permissions#Unhide_the_hidden_files

    Thanks, but when I click “View” from the top let of my FTP client, there is no option for showing hidden files, and for that matter, that option doesn’t show when I try clicking anything else. I use Cute FTP. I tried going into my site manger, but I don’t see anything there for advanced options.

    Sorry. Maybe I’m just thick. I checked out the link you just sent me. But what I still don’t understand is which file I’m supposed to do the whole CHMOD routine on in order for my .htaccess file to become unhidden. I also tried doing the filter option specified in the tutorial, but it’s not working.

    You don’t need to do the CHMOD part yet. That was just a guide as to how you can CHMOD or show hidden files. I don’t use cuteftp but if that section on showing the hidden files doesn’t work, then you’ll prolly have to search the cuteftp help files. Or you could just go and download filezilla, which is free.

    Lawtai, I already have filezilla, but I was having trouble connecting with that program, so instead, I went with the Cute FTP. In terms of cuteftp help, I tried doing what the help file suggested, but nothing happened. Is it possible to switch FTP servers without having to reinstall WordPress again? Thanks.

    Actually, I still have filezilla, and I was able to access my WordPress program. But nothing happened when I clicked on “show hidden files” Where would the hidden files show up?

    Thanks again.
    Lisa

    I believe you’ll first need to create a .htaccess file. You can do this by saving a blank notepad file as .htaccess. You’ll next need to upload it to your root directory of wordpress. Then you’ll need to show hidden files in order to see it, and then CHMOD the .htaccess to atleast 666 in order for WP to write to it.

    Thanks. Is the root directory the same thing as the default directory given by my hosting provider?

    root directory as in where you have WP installed. So if WP is instealled in a folder /wordpress, then put your .htacces in there. The link that Kafkaesqui posted earlier tells you how to go about doing this.

    For me, my default directory is httpdocs. That’s where I have wp-admin, wp-contents, wp-images, wp-includes, index.php, wp.php, etc. Does that sound right to you.

    Thanks again,
    Lisa

    yea, put your .htaccess file in there.

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘Problem With Comments on My Blog’ is closed to new replies.