WordPress.org

Support

Support » Themes and Templates » problem with the comment system

problem with the comment system

  • I have got the theme PressRow activated right now and comments won’t go through. Due to 405 error and other time it says done but hangs up by wp-comment-post.php, but nothing happens or gets posted. Before the error I updated my wordpress to 2.2. Any suggestions would be greatly appreciate. All the options set right now allows comments to go through. So either it is the theme or wordpress? Not sure what to do as I want my comment system up and running, as it is vital to My site – Venter.

    Cheers Thanks for your help

Viewing 11 replies - 1 through 11 (of 11 total)
  • So do comments work if you temporarily change to the Default theme?

    What version of WP were you running before the upgrade? Have you confirmed all your plugins work with the latest version?

    No, comments don’t work if I change the theme to Default! I was running 2.1 when the first release of it came out.

    You think it could be a plugin though? I’ll check that. But what are your thoughts, has there been any bugs like this in this release of wp?

    Cheers Dave

    Yeah, plugin is where I’d definitely start.I’m not familiar with an error like what you’re seeing (and I’ll confess I didn’t do much searching here in the forums…)

    You might check: http://codex.wordpress.org/Plugins/Plugin_Compatibility/2.2

    Make sure you have latest versions of all your plugins.

    Disable ’em all. Do comments work? Enable one by one checking comments as you go.

    Checked to see if it was the plugins when i disabled them all but it wasn’t. Where do you think I should go next anybody?

    Doesn’t matter what theme I use either! Must be problem or bug with WP 2.2?

    I have the same problem – comments act like they are going to work, but no comments are posted. Also, perhaps related, I can’t upload any files – again, it acts like the files are uploaded, but they don’t show up in the upload manager or in the uploads directory. (using 2.2.1)

    When I switch to Classic theme, I get a 405 error from wp-comments-post.php: This error (HTTP 405 Method Not Allowed) means that Internet Explorer was able to connect to the website, but the site has a programming error.

    Indeed, looking at the server logs, when I click Submit, the server sees a POST, but 301 redirects it to wp-comments-post.php (right back to itself?) but it comes as a GET, and the error-checking at the top of wp-comments-post.php returns a 405.

    But, I I don’t understand why it redirects back to itself.

    Is there any fix to this problem?

    Yes, I think so. The problem seems to be that in the Options->General settings, I had the “WordPress address (URL):” and “Blog address (URL):” set to “http://myblog.com”, instead of “http://www.myblog.com” (I.e., I didn’t have the “www.” in front of the domain.

    Since I have my webserver set up to redirect myblog.com to http://www.myblog.com, the redirect happened, causing a GET to be used instead of a POST (that seems like an odd thing for Apache to do, but so it seems).

    Nonetheless, I made the change in my Options, and all seems well.

    Best of luck.

    Totally worked Bro! Thanks alot.

    i had “Users must be registered and logged in to comment” checked, and that gave me the problem above. Once i unchecked it. everything worked. like martinw, it also had my apache server redirect subdomain.domain.com/wordpress to http://www.mydomain.com, not sure if that’s the reason that caused it though.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘problem with the comment system’ is closed to new replies.
Skip to toolbar