Support » Plugin: Mollie Payments for WooCommerce » Problem with checkout on Polylang-enabled webshop -> redirect 404

  • Hi there,

    I have this issue +/- => https://github.com/mollie/WooCommerce/issues/173
    However I’m using the Polylang Pro + Polylang for wooCommerce.

    After checkout and going via Mollie payment, I get a 404. If I manually remove the language-code from the URL it works.

    Example:
    1. Checkout + Pay (via Mollie for WooCommerce – credit card)
    2. System redirects to <my-domain>/nl/wc-api/mollie_return/?order_id=1778&key=wc_order_TaBuOOn8GNKYN
    => this gives a 404 error, when I remove the /nl/ from the URL above then it redirects to working page, like this one: /nl/checkout/order-received/1784/?key=wc_order_HNmsbsM6tGfQH&utm_nooverride=1

    Any thoughts? This is urgent (webshop needs to go live in a week).
    I can also give you admin access to investigate.

    I also contacted Polylang support, they say the problem is on the side of the “Mollie for WooCommerce” plugin.

    Thank you very much!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Christina Fuchs

    (@vanvox)

    Hi @forevah

    sorry for the issues you’re having with our plugin. Please send an email to mollie[at]inpsyde.com and mention this thread. Our support team will try to help but can take some time.

    Kind regards
    Christina

    Plugin Author Dario

    (@darioinpsyde)

    Hello @forevah,

    please, as @vanvox said, contact us via email at mollie[at]inpsyde.com mentioning this thread and forwarding also all the info needed to investigate the issue.

    Best regards,
    Dario

    • This reply was modified 3 months, 3 weeks ago by  Dario.

    I ‘fixed’ it with a .htaccess rule

    # Quick fix/hack for the Mollie redirect problem:
    RewriteEngine On
    RewriteRule ^nl/wc-api/(.*)$ /wc-api/$1 [R=301,L]
    RewriteRule ^fr/wc-api/(.*)$ /wc-api/$1 [R=301,L]
    RewriteRule ^en/wc-api/(.*)$ /wc-api/$1 [R=301,L]
    # Add more languages if needed…

    Plugin Author Guido Scialfa

    (@wido)

    Have you tried to update to the latest Polylang Pro and Polylang for WooCommerce?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Problem with checkout on Polylang-enabled webshop -> redirect 404’ is closed to new replies.