WordPress.org

Support

Support » Plugins and Hacks » Problem with category archive in secondary language

Problem with category archive in secondary language

  • Hi,

    When I go to a category archive in secondary language I get an 404 error.
    With primary language it’s working.

    Please can somebody help?

    – Permalinks settings:
    /%category%/%postname%/
    Base category: . (I use a dot to avoid “/category/” slug)
    – I’m using a static front page
    – Polylang settings (translated from spanish):
    lang in directory name in permalink (/en/my-post/)
    hide url in default lang
    delete /language/ in custom permalinks
    home shows language code instead it’s name or id
    Lang acording to browser preferences

    http://wordpress.org/extend/plugins/polylang/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Chouby

    @chouby

    Hi!

    Base category: . (I use a dot to avoid “/category/” slug)

    Maybe this is not supported by Polylang. Could you check that this is not the source of your problem?

    Yes.. that was the problem,

    I tried to change this before your answer and now it works fine…

    Right now I’m going to use this but I would like to avoid category slug…

    Thanks for your answer

    Plugin Author Chouby

    @chouby

    It’s rather strange because meanwhile, I made the test with WP 3.9.1 + Twenty Fourteen 1.1 + Polylang 1.5, and it works. So maybe there is another source of conflict.

    Maybe it’s caused by the theme… I’m using Divi theme from Elegant Themes.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Problem with category archive in secondary language’ is closed to new replies.