Support » Plugin: WordPress HTTPS (SSL) » Problem with Cart66 checkout JS

  • Resolved jfacemyer


    I’ve had https working nicely on my Cart66 store, but a recent update has caused a small hiccup.

    I only see it on Chrome.

    The upgraded Cart66 features a real-time check once you put the zipcode in and tab/click out of the field. Unfortunately, it is broken when used in conjunction with WP-HTTPS.

    Before entering the zipcode (and state), the page shows everything as secure. But after, it shows being partially unsecure.

    The Chrome console says: displayed insecure content from

    You can see the problem if you add an item and check out at

    Any ideas what the issue is?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Mike Ems


    I’m guessing you have Force SSL Exclusively on. The plugin is changing the AJAX url to HTTP since that URL is not being secured in any way and the plugin has no way to know that the URL is being used for AJAX and to leave it as HTTPS. Try adding this to your URL Filters \?cart66Ajax



    Thanks for the reply!

    I tried the filter, but when I tried adding an item to the cart (which also uses AJAX), I think the same thing happened. Whereas in the original state the broken AJAX link isn’t a game stopper (it just doesn’t update shipping in case of a zipcode mismatch, which is unlikely to be a problem), in this case it is.

    Any further ideas?

    Plugin Author Mike Ems


    I don’t understand. Explain exactly what you’re doing. I need to know what’s happening. I can visit the site and I don’t see any issues.



    I apologize – I thought I was being clear, but that’s not always easy to know from this side of the problem 🙂 Thanks again for responding!

    To reproduce:

    1. Go to the site in Chrome.
    2. Add something in the store.
    3. View Cart and enter zipcode.
    4. Click Checkout.
    * Notice that Chrome shows the page as secure.
    5. Enter your state, then enter your zipcode and tab out of the zipcode field.
    * Notice that the activity animation next to Total doesn’t stop (because the script isn’t loading correctly, I assume). Notice also that the security indicator has changed to say that some elements are insecure.

    I attempted to add the filter as you recommended above, but then I can’t add anything to the cart (it just hangs – items are added by AJAX), so I removed the filter.

    My settings:

    Force SSL Admin (checked)
    Force SSL Exclusively (checked)
    Remove Unsecure Elements (NOT checked)
    Debug Mode (NOT checked)
    Proxy (No)
    Domain Mapping (blank)
    URL Filters (blank)

    Just wondering if there are any thoughts on this – I’ve still got this problem.


    Plugin Author Mike Ems


    The only fix to your issue is to add the URL Filter I mentioned earlier. If that causes it to not work, that means there is a separate problem that needs to be analyzed, but adding the filter is necessary.

    Kinda the same thing here.
    I had HTTPS with URL filter /store/checkout
    and the mentioned \?cart66Ajax
    But that gave a problem when trying to put something in the cart; I got a popup saying ReadyState: 0 and nothing happened.

    Put this in your URL Filters (so not only the checkout page):

    Dude! That worked! It makes sense, but I didn’t think of it.

    Problem solved by zudie!


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Problem with Cart66 checkout JS’ is closed to new replies.