WordPress HTTPS (SSL)
[resolved] Problem with Cart66 checkout JS (9 posts)

  1. jfacemyer
    Posted 3 years ago #

    I've had https working nicely on my Cart66 store, but a recent update has caused a small hiccup.

    I only see it on Chrome.

    The upgraded Cart66 features a real-time check once you put the zipcode in and tab/click out of the field. Unfortunately, it is broken when used in conjunction with WP-HTTPS.

    Before entering the zipcode (and state), the page shows everything as secure. But after, it shows being partially unsecure.

    The Chrome console says:

    https://www.vianneyvocations.com/store/checkout/ displayed insecure content from http://www.vianneyvocations.com/?cart66AjaxCartRequests=4

    You can see the problem if you add an item and check out at http://www.vianneyvocations.com/store/

    Any ideas what the issue is?


  2. Mike Ems
    Plugin Author

    Posted 3 years ago #

    I'm guessing you have Force SSL Exclusively on. The plugin is changing the AJAX url to HTTP since that URL is not being secured in any way and the plugin has no way to know that the URL is being used for AJAX and to leave it as HTTPS. Try adding this to your URL Filters \?cart66Ajax

  3. jfacemyer
    Posted 3 years ago #

    Thanks for the reply!

    I tried the filter, but when I tried adding an item to the cart (which also uses AJAX), I think the same thing happened. Whereas in the original state the broken AJAX link isn't a game stopper (it just doesn't update shipping in case of a zipcode mismatch, which is unlikely to be a problem), in this case it is.

    Any further ideas?

  4. Mike Ems
    Plugin Author

    Posted 3 years ago #

    I don't understand. Explain exactly what you're doing. I need to know what's happening. I can visit the site and I don't see any issues.

  5. jfacemyer
    Posted 3 years ago #

    I apologize - I thought I was being clear, but that's not always easy to know from this side of the problem :) Thanks again for responding!

    To reproduce:

    1. Go to the site in Chrome.
    2. Add something in the store.
    3. View Cart and enter zipcode.
    4. Click Checkout.
    * Notice that Chrome shows the page as secure.
    5. Enter your state, then enter your zipcode and tab out of the zipcode field.
    * Notice that the activity animation next to Total doesn't stop (because the script isn't loading correctly, I assume). Notice also that the security indicator has changed to say that some elements are insecure.

    I attempted to add the filter as you recommended above, but then I can't add anything to the cart (it just hangs - items are added by AJAX), so I removed the filter.

    My settings:

    Force SSL Admin (checked)
    Force SSL Exclusively (checked)
    Remove Unsecure Elements (NOT checked)
    Debug Mode (NOT checked)
    Proxy (No)
    Domain Mapping (blank)
    URL Filters (blank)

  6. jfacemyer
    Posted 3 years ago #

    Just wondering if there are any thoughts on this - I've still got this problem.


  7. Mike Ems
    Plugin Author

    Posted 3 years ago #

    The only fix to your issue is to add the URL Filter I mentioned earlier. If that causes it to not work, that means there is a separate problem that needs to be analyzed, but adding the filter is necessary.

  8. zudie
    Posted 3 years ago #

    Kinda the same thing here.
    I had HTTPS with URL filter /store/checkout
    and the mentioned \?cart66Ajax
    But that gave a problem when trying to put something in the cart; I got a popup saying ReadyState: 0 and nothing happened.

    Put this in your URL Filters (so not only the checkout page):

  9. jfacemyer
    Posted 3 years ago #

    Dude! That worked! It makes sense, but I didn't think of it.

    Problem solved by zudie!


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic