Support » Plugin: PageSpeed Ninja » Problem with canonical tag

  • Resolved stevenmonson

    (@stevenmonson)


    Thanks so much for the plugin.

    I noticed that when the plugin in activated, it changes my canonical tag from the full URL to just “/”, which is incorrect formatting for a canonical tag.

    Whenever I run the Google Lighthouse Test it reduces my SEO score as a result of this.

    Do you know why the plugin is modifying the canonical tag? Is there a setting I can change to tell the plugin to leave the canonical tag alone?

    Thanks so much!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Denis Ryabov

    (@dryabov)

    It’s because of “Minify URLs” option is enabled in the “Minify HTML” section of Advanced settings. Just set it disabled. We will fix it in the next release to don’t affect canonical URL.

    Plugin Author Denis Ryabov

    (@dryabov)

    Fixed in 0.9.21.

    thanks its save me the same problem with me now its fix i was hit by a black hat seo copy all my seo content and still this website want to rank 2 to goggles non stop he hit all many website with cloacking redirecting and spamming stealing many well know website i don’t why goggles did not detect website..

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Problem with canonical tag’ is closed to new replies.