Support » Plugin: Calculated Fields Form » problem with calculated field

  • Resolved mhecht2013

    (@mhecht2013)


    Hi, plugin is great.
    Is it possible that an equation of a fielname is a result of other calculated fields ?
    Fieldname 4 = calculated fieldname1 + calculated fieldname2 +…
    I have tried to make it simple as an addition but it failed.

    Do I have to type and add all the equations related to each calculated fieldname 1, 2,… into the Fieldname 4 or is there a simpler way ?

    Forgive my ignorance.
    Thank you in advance.

    http://wordpress.org/plugins/calculated-fields-form/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author codepeople

    (@codepeople)

    Hi,

    You may have multiple calculated fields, where one of them is the sum of the others, for example suppose we have four calculated fields: fieldname1, fieldname2, fieldname3 and fieldname4, with the corresponding equations, and one additional calculated fields fieldname5 whose equation is:

    fieldname1+fieldname2+fieldname3+fieldname4

    You only must be sure not created a loop between the equations.

    Thank you for your reply.
    I don’t think I have created a loop.
    In addition, I have added some new fieldnames and they didn’t show up in the form.
    I really do not know what is happening.
    Would you help and look at the form please ?
    The webpage is the same as previous ticket.

    Plugin Author codepeople

    (@codepeople)

    Hi,

    I’ve detected the issue in your form, first all, you should correct the structure of tags used in the attribute “label”, in multiple fields, because the structure used is not correct.

    And finally, and this part is very important, go to the calculated field:

    “Economies d’eau en m3”

    and set an space in the suffix attribute.

    Best regards.

    Waow !
    As I don’t want to die totally ignorant, could you explain why a simple space in the suffix attribute has solved the problem ?
    Thank you very much.
    Best regards

    Plugin Author codepeople

    (@codepeople)

    Hi,

    Previously was entered an invalid character in the “suffix” attribute of the field. So, is required to type a new value in the “suffix” attribute, to update the attribute’s value in database.

    Hi,
    I have calculation problem. Every time I try to insert multiplication with number smaller then 1 shows me not precision number: For example:
    3*0.1=0.30000000000000004

    Can you please advice? Thank you.

    Plugin Author codepeople

    (@codepeople)

    Hi,

    This issue occur in the javascript engine, to get a precise number, uses the “prec” operation:

    prec(3*0.1,2)

    the result will be:

    0.30

    Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘problem with calculated field’ is closed to new replies.