Support » Plugin: SG Optimizer » Problem with cache when editing posts

  • Resolved Kim Soler

    (@kimso)


    I have a problem with cache in the dashboard, when I save a post, the content appear like it there’s no content but if I preview the post, I can see the content. If I clear cache, the content appears.

    I configured to exclude this /wp-admin/ and /wp-admin/* but if check if a page is in cache and I use this /wp-admin/post.php?post=34&action=edit it says it’s in cache.

    If I exclude *wp-admin* it seems to work with the administrator role but not for editor role.

    I don’t understand why you don’t configure by default to ignore cache in the back-end.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Nothing is cached for logged users. It is ignored. The check fails in your case because it’s not designed to check files (even .php) but folders only. We will fix that in the next release but surely, everything in the backend is dynamic.

    That sounds more like static cache, rather than anything else. If you want to be extra sure, you can check the headers coming from the server. x-proxy-cache: HIT means it’s cached while a MISS or BYPASS – a dynamic hit.

    It was problem with Memcached using the plugin Polylang. If I disable Memcached in SG Optimizer settings it works correctly.

    It’s strange because I have tested with several versions of SG Optimizer and this problem is present since version 5.0.9. In versions 5.0.8 and 5.0.1 this problem wasn’t present.

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    We used different Memcached dropin which we then replaced with the previous one that has proven to work much better. Maybe it has been working better with Polylang but unfortunatelly, it was way too aggressive and broke things like WooCommerce orders, etc.

    If you’re using Polylang or WPML, just keep Memcached disabled until they can support it properly.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Problem with cache when editing posts’ is closed to new replies.