Support » Theme: evolve » Problem with breadcrumbs

  • Resolved tutumu

    (@tutumu)


    Hello.

    I have a problema with breadcrumbs in my web with Evolve theme. Breadcrumb separators are deformated.

    The problem happens with Wp4 and WP5 versions.

    What can I do?

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hello @tutumu,

    it seems a plugin conflict with a cookie plugin. Please try to deactivate it to check if it helps 😉

    Thread Starter tutumu

    (@tutumu)

    First, thany you very much for response.

    I have “Cookie Notice” plugin for cookies. Plugin is updated. I’ve deactivated this plugin but my problem continues… breadcrumbs are deformated.

    I’ll keep deactivated the plugin so you can review all.

    try deactivate the child theme, if it’s correctly defined.

    Thread Starter tutumu

    (@tutumu)

    I tried to deactivate child theme and… then breadrumbs are OK!

    But I don’t understand, my child theme is very basic.. I’ve tried to deactivate all archives changed and keeping only the style.css and functions.php files. But by this way breadcrumbs don’t work ok.

    The content of these files is standard… I paste it.

    Style.css

    /* 
    Theme Name:		 evolve child theme
    Theme URI:		 http://www.websitebundles.com/
    Description:	 Theme by Site <a href=\"http://childthemegenerator.com/\">http://childthemegenerator.com/</a>
    Author:			 WebsiteBundles
    Author URI:		 http://childthemegenerator.com/
    Template:		 evolve
    Version:		 1.0.0
    Text Domain:	 evolve-childNEW
    -------------------------------------------------------------- */ 
    
    /* Aqui empieza la personalizacion del tema
    ------------------------------------------------------- */

    functions.php:

    <?php
    /* CODIGO ACTIVACION PLANTILLA CSS TEMA PADRE*/
    add_action( 'wp_enqueue_scripts', 'theme_enqueue_styles' );
    function theme_enqueue_styles() {
        wp_enqueue_style( 'parent-style', get_template_directory_uri() . '/style.css' );
        wp_enqueue_style( 'child-style', get_stylesheet_directory_uri() . '/style.css', array('parent-style')
        );
    }
    
    /* Cambiar texto de read more
    function be_excerpt_more( $more ) {
    	return 'Leer más';
    }
    add_filter( 'excerpt_more', 'be_excerpt_more' );*/
    
    ?>

    Any suggestion? Thanks.

    use a child theme configurator plugin. Styles are not defined correctly

    Thread Starter tutumu

    (@tutumu)

    Hello.

    I’ve configured a new child theme (with another code) and problem with breadcrumbs continues. So I’ve returned to old child theme.

    This is the code of new child theme for test:

    functions.php

    <?php
    add_action( 'wp_enqueue_scripts', 'theme_slug_enqueue_styles' );
    function theme_slug_enqueue_styles() {
        $parent_style = 'evolve-style'; // Tema padre
        wp_enqueue_style( $parent_style, get_template_directory_uri() . '/style.css' );
        wp_enqueue_style( 'child-style',
            get_stylesheet_directory_uri() . '/style.css',
            array( $parent_style ),
            wp_get_theme()->get('Version')
        );
    }
    ?>

    style.css

    /* 
    Theme Name:		 evolve child theme
    Theme URI:		 https://theme4press.com/evolve-multipurpose-wordpress-theme/
    Description:	 evolve by Theme4Press is an eye-catching and minimal WordPress theme built for web enthusiasts who like effective yet sweet website
    Author:			 Theme4Press
    Author URI:		 https://theme4press.com
    Template:		 evolve
    Version:		 1.0.0
    Text Domain:	 evolve-child
    -------------------------------------------------------------- */

    Is it possible that is there a problem of compatiblity with breadcrumbs and child themes?

    Thanks.

    the definition in the functions.php is not correct. Correct is:

    // Enqueue parent action
    
    if ( ! function_exists( 'evolve_parent_css' ) ) {
    	function evolve_parent_css() {
    		wp_enqueue_style( 'evolve-parent', trailingslashit( get_template_directory_uri() ) . 'style.css', array( 'evolve-bootstrap' ) );
    	}
    }
    add_action( 'wp_enqueue_scripts', 'evolve_parent_css', 10 );
    Thread Starter tutumu

    (@tutumu)

    Finally I’ve reasearched and I’ve got a solution for my problem editing CSS style on child theme. I’ve added this code and now breadcrumbs works ok:

    .breadcrumb-item:before {
    	border: none !important;
    	padding: 0 !important;
      transform: none !important;
      -ms-transform: none !important;
      -webkit-transform: none !important;
      vertical-align: 0 !important;
    }

    Thank you

    Thread Starter tutumu

    (@tutumu)

    Tested with the function that you say for functions.php file and works perfectly too (without changes on css style). Better on this way… code more clear.

    Thank you very much!!

    you are welcome 😉

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Problem with breadcrumbs’ is closed to new replies.