Support » Themes and Templates » Problem with ‘Blix’ Theme

  • Resolved shycircus

    (@shycircus)


    I wonder if anyone can help me?

    I recently set up the Blix theme at my wordpress: http://shycircus.org and would love to have some more pages to my site – however when I create a new page it doesn’t appear in the menu (at the top under the picture banner) – does anyone know why this is? And how to fix it?

    Thankyou

Viewing 2 replies - 1 through 2 (of 2 total)
  • The problem here is that the Blix theme is rather old. On its homepage, it states:

    ‘Blix’ is a freely available theme for WordPress 1.5.

    I just installed it locally and am experiencing the exact same problem you are. This is due to the fact that the themes uses a custom query to get page links in header.php

    Around line 35, you will see this block of code:

    $pages = BX_get_pages();
    		if ($pages) {
    			foreach ($pages as $page) {
    				$page_id = $page->ID;
       				$page_title = $page->post_title;
       				$page_name = $page->post_name;
       				if ($page_name == "archives") {
       					(is_page($page_id) || is_archive() || is_search() || is_single())?$selected = ' class="selected"':$selected='';
       					echo "<li".$selected."><a href=\"".get_page_link($page_id)."\">Archives</a></li>\n";
       				}
       				elseif($page_name == "about") {
       					(is_page($page_id))?$selected = ' class="selected"':$selected='';
       					echo "<li".$selected."><a href=\"".get_page_link($page_id)."\">About</a></li>\n";
       				}
       				elseif ($page_name == "contact") {
       					(is_page($page_id))?$selected = ' class="selected"':$selected='';
       					echo "<li".$selected."><a href=\"".get_page_link($page_id)."\">Contact</a></li>\n";
       				}
       				elseif ($page_name == "about_short") {/*ignore*/}
               	 	else {
                		(is_page($page_id))?$selected = ' class="selected"':$selected='';
                		echo "<li".$selected."><a href=\"".get_page_link($page_id)."\">$page_title</a></li>\n";
                	}
        		}
        	}

    Delete it and replace with:

    wp_list_pages('title_li=&depth=1');

    This worked for me but I would strongly suggest going with another theme that is more up to date.

    Thankyou very much!
    It worked for me too.

    I will keep my eyes open for a more up-to-date theme for the future 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Problem with ‘Blix’ Theme’ is closed to new replies.