Support » Plugin: Age Gate » [NSFW] Problem with background and age-gate-form

  • Resolved christofer92

    (@christofer92)


    Hello,

    I have a problem with my adult porn-site and especially the background and age form for mobile devices

    Now I have the background at 100% on all sides (I should change because I don’t like it) and the age form shrunk, how can I enlarge it in full?

    i have this problem only in smartphones

    Thanks in advance

    • This topic was modified 2 months, 1 week ago by christofer92.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Phil

    (@philsbury)

    Hi @christofer92,

    Do you have the “Viewport meta tag” option checked in the Age Gate appearance settings, that’d probably be my first guess. Try with it the opposite of what you have.

    If that doesn’t work and you have a link, I’ll happily have a look.

    Thanks
    Phil

    perfect @philsbury..now it works. It was disabled

    Two more things if I can:

    1) when the mouse passes over the YES and NO buttons the hover color remains gray, how can I change it?

    2) Is it possible to make css edits for desktop only and mobile only?

    to insert different measures

    thanks 🙂

    • This reply was modified 2 months, 1 week ago by christofer92.
    Plugin Author Phil

    (@philsbury)

    Hi @christofer92,

    Glad that bit is sorted!

    For the other two, yes but you’ll need to write a bit of CSS.

    The hovers can be done with some like:

    
    .age-gate-submit-yes:hover,
    .age-gate-submit-no:hover {
        background-color: red;
    }
    

    Sticking with that as an example, you could then change those colours for mobile with:

    
    @media screen and (max-width: 1023px) {
        .age-gate-submit-yes:hover,
        .age-gate-submit-no:hover {
            background-color: green;
        }
    }
    

    Full snippet for that would be

    
    .age-gate-submit-yes:hover,
    .age-gate-submit-no:hover {
        background-color: red;
    }
    
    @media screen and (max-width: 1023px) {
        .age-gate-submit-yes:hover,
        .age-gate-submit-no:hover {
            background-color: green;
        }
    }
    

    You can either add that to your theme’s css or in the CSS editor in the age gate advanced settings. There’s reference to all the CSS selectors here

    Thanks
    Phil

    christofer92

    (@christofer92)

    HI @philsbury

    thank you so much,

    for the mobile and desktop part all clear, I am already making the appropriate changes and everything works

    But the code: hover does not work, it continues to remain gray

    adult site link: https: //hentaianimehub.com/

    Thanks so much again

    Plugin Author Phil

    (@philsbury)

    Hi @christofer92,

    Something on your site is setting it with an !important flag, so you’ll have to do the same, or remove the important that is being set:

    
    .age-gate-submit-yes:hover,
    .age-gate-submit-no:hover {
        background-color: red !important;
    }
    

    Thanks
    Phil

    christofer92

    (@christofer92)

    Hi @philsbury

    I thank you infinitely

    now everything works, I close the post

    Thanks again

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.