Support » Fixing WordPress » Problem with automatic updating plugins although WP says it has.

  • Resolved lcerura

    (@lcerura)


    Hi, I had migrated all my domains from one host to another. This problem exists on only one domain at which I’ve got two WordPress sites.

    WP would tell me what updates are pending and I’ll go in and do an automatic update for each plugin. The following is what I get:

    The update process is starting. This process may take a while on some hosts, so please be patient.

    Updating Plugin Redirection (1/1)
    Redirection updated successfully. Show Details.

    All updates have been completed.

    BUT, thereafter, nothing’s changed. It’s as if the update never ever took place. Went into one of the plugin folders to check on the file and the version is still the old one.

    Mind you, the same problem applied to the version of WP as well. A manual update of WP as well as a few plugins worked well. BUT, I know something somewhere is wrong because of the above.

    Any ideas, clues, suggestions would be appreciated. Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Mind you, I’ve seen this problem posted previously. Back then some solutions were:

    – to change the permissions,
    – another suggested a cache problem at the host
    – clearing browser cache
    – checking on the tables (repair and more) within PHP admin

    I’ve played with the permission and cleared the browser cache repeatedly but to no avail.

    As for a cache problem at the host, all my domains are under the same host. I somehow doubt that’s the problem since the problem exists at only one domain.

    Going into PHP admin and looking for problems there revealed little.

    Okay, I finally got through to my host after spotting some online references to the following:

    chown -R apache:apache

    chown -R www-data:www-data /var/www

    Not that it meant anything to me at the time. But my host was quick to jump to my rescue.

    They also pointed me to some links to educate myself a little on the subject. One of which is:

    DSO (mod_php) vs. CGI vs. suPHP vs. FastCGI

    Seeing’s how the problem’s been raised online so often with little to no solution(s)…I hope this helps someone else. 😉

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Problem with automatic updating plugins although WP says it has.’ is closed to new replies.