Support » Plugin: SendGrid » Problem with auto save API key

  • The page where I can fill in the API autosaves if I enter the key, but the problem is in Google Chrome autofill is on and it fills that field with something else. After that it autosaves. Could you please fix this and not autosave the settings page.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author SendGrid INC

    (@team-rs)

    Hello! Our Support team would be happy to assist you with this via our website. This forum is monitored but not an active support channel- our site allows you to contact Support directly. We apologize for the delayed response to your issue and would like to provide support as soon as possible.

    For assistance please contact SendGrid Support from the SendGrid Support Portal – https://support.sendgrid.com/. Click Login & Contact Support, and then Contact Support to see your support contact options. Paying SendGrid customers have the option to contact support via phone, chat, or by submitting a ticket using our web form. All SendGrid customers have the option to submit a ticket using our web form. Thank you!

    same problem here

    Same problem happening on three sites, the API key is autofilled in and can not copy the API key and add in the other details before this shows on the settings page.

    WP-Admin > Settings > SendGrid

    API Key is invalid or without permissions.

    same problem here

    • This reply was modified 1 year, 1 month ago by  eArtboard.

    same issue.

    i don’t understand why they will use such method

    Same problem for me as well

    So found a easy workaround if you are having the issue – for me it was Google Chrome – so I just used Firefox instead and it worked 🙂

    Rocky Kev

    (@rockykev)

    Solved!

    I found the issue. If you have auto-fill, your browser sees the API box as a field it wants to auto-fill.

    Sendgrid’s plugin automatically updates when there’s content in there.

    Result – your browser keeps putting info in there, Sendgrid’s plugin keeps refreshing… it keeps looping and breaking.

    HOW TO FIX:
    I opened it in incognitomode (where there was no auto-fill) and put everything. Works now. And I’m aware you might have moved on already, but this is for anyone who needs help.

    Yes, this is still a major issue.

    Today I have the same problem.
    I disabled the password save in my site, and then I can config it.
    Is a great plugin, but nobody knows if they cannot use it!

    I reported to Sendgrid, I will looking for their answer

    Regards,
    Urano

    This issue is present for me in Chrome, Chrome Incognito, Firefox and Firefox Private Browsing. The plugin is unusable as a result. I also tried disabling Save Passwords in Firefox, same result.

    arnolp

    (@arnolp)

    That’s a pain … have to disable auto save passwords on all my wordpresses just because of this settings page crap UX.
    Just add a button to validate instead !

    Same issue here, very frustrating. Worked in Chrome Incognito… good suggestion, @rockykev!

    @team-rs would love to see you all resolve this.

    The issue was solved for me by stopping the page when it tries to auto load, and then pasting in the correct API key.

    If you get an error message it’ll be because you haven’t added the site’s IP to the whitelist so it errors and then autofills with the wrong info.

    So if you have setup sendgrid correct the API key will then be accepted.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Problem with auto save API key’ is closed to new replies.