WordPress.org

Forums

Private groups
[resolved] problem with array (26 posts)

  1. pooyasas
    Member
    Posted 1 year ago #

    Hi, please help me. I've installed the plugin, created forums and users and groups of users. I restricted the forum to certain groups but this message appears in all the pages of the forum:

    Warning: array_merge(): Argument #2 is not an array in /web/htdocs/www.sportiva-mente.it/home/wp-content/plugins/bbpress/includes/common/functions.php on line 1300 - See more at: http://www.sportiva-mente.it/forums/#sthash.PJjYB4je.dpuf

    you can see it at http://www.sportiva-mente.it/forums/
    What happened?
    Thank you very muche and please sorry for my english.

    https://wordpress.org/plugins/bbp-private-groups/

  2. Robin W
    Member
    Plugin Author

    Posted 1 year ago #

    There is an error that is occurring with very few users (3 so far) of the latest version.

    I have not tracked down why yet, but can you revert to the previous version 1.8.1 which is here

    http://www.rewweb.co.uk/bbp-private-groups/

    you need to download version 1.8.1

    If you are available to do some simple tests to help me eliminate this, please come back.

  3. pooyasas
    Member
    Posted 1 year ago #

    It runs! thank you very much.

    I need to inser a user in multiple group, is it possible? how?

  4. Robin W
    Member
    Plugin Author

    Posted 1 year ago #

    users only belong to one group.

    Forums have multiple groups associated with them

    what are you trying to achieve? Describe please !

  5. Robin W
    Member
    Plugin Author

    Posted 1 year ago #

    pooyasas

    I am still trying to track down your original error, which I can't replicate on my test site, and only two others have seen this.

    Would it be possible for you to test a different version of the plugin? You'd just need to install, switch to this version and see if the error is there or not, and then switch back - I'll give you full instructions. Let me know.

  6. Zdev1
    Member
    Posted 1 year ago #

    Getting this error after I updated to the latest version Version 1.9.1 now I'm not seeing the main forum landing page. I did nothing else but click the auto update. :(

    Warning: array_merge(): Argument #2 is not an array in /home/content/p3nexnas05_data01/83/2102083/html/wp-content/plugins/bbpress/includes/common/functions.php on line 1344

  7. Robin W
    Member
    Plugin Author

    Posted 1 year ago #

    There is an error that is occurring with very few users (4 so far) of the latest version.

    I have not tracked down why yet, but can you revert to the previous version 1.8.1 which is here

    http://www.rewweb.co.uk/bbp-private-groups/

    you need to download version 1.8.1

    If you are available to do some simple tests to help me eliminate this, please come back. Until someone helps me, I'm afraid you'll need to stick at 1.8.1.

  8. Zdev1
    Member
    Posted 1 year ago #

    I'll help you test, just let me know what you'd like me to try. Just from reading the posts above me, I'll for now assume you'd like me ti install the older version then re-update that to the new one just to see what happens? Correct?

    I'll try that right now, if you need something else done just drop me another post.

  9. Zdev1
    Member
    Posted 1 year ago #

    Ok, I fully deactivated AND uninstalled the new version, uploaded, installed and activated the 1.8.1 version and no problem what so ever.

    EVEN the original settings were there again although I flushed the cache and everything. My 8 groups that I created in 1.8.1 was also there. Not certain how all this set itself back up to what I had originally set it to, but it did.

    Once I made sure 1.8.1 was working exactly like it was before, I then clicked to update to the newer version. I then loaded my forum in a new page and got that same exact error once again.

    Hope this helps!

  10. Robin W
    Member
    Plugin Author

    Posted 1 year ago #

    Zdev1, brilliant, thanks for doing that, it proves that I have got it wrong somewhere. That it is only affecting some users probably means it is in combination with something else, but whatever the cause, it needs fixing !

    Ok I did several changes between 1.8.1 and 1.9.1, and I need to work out which of these is causing the problem.

    Can you do the following for me?

    I have therefore made a version that contains some of the changes, and if you are happy to help, it would be great if you could try this version to see if the error remains or goes away. After that I would need you to do the same probably a couple more times just to get to a resolution.

    This will enable you to take advantage of the improvements which I plan for this plugin.

    Could you therefore follow these instructions – it may help to print them

    1. Go to the following site and download and save the test version to your PC, making a note of which directory you save it in.
    http://www.rewweb.co.uk/private-groups-plugin-test-version
    2. Go into your website and go into
    a. Dashboard>plugins>add new plugin>upload and browse to the file you just saved
    b. Click install now, BUT DO NOT CLICK ‘ACTIVATE’ AFTER THIS STEP
    c. Click ‘return to plugins page’
    d. You will see that you now have the original ‘bbp private groups’ plugin and a new ‘bbp private groups test’
    e. Deactivate the original ‘bbp private groups’
    f. Activate the new ‘bbp private groups test’
    3. Then test to see if this works without error
    4. Then deactivate the ‘bbp private groups test’ and activate the ‘bbp private groups’ so that you have a working site again.

    Then let me know if the test version worked without error, or whether it still had the same error (or indeed a different error).

    This will let me know which 50% of my changes are fine, and which I need to test further.

    You help will help me resolve this error.

  11. Zdev1
    Member
    Posted 1 year ago #

    Robin, I followed your instructions exactly as you said, and I got no errors with the ‘bbp private groups test’ at all. I looked into each and every forum just trying to find anything out of the norm, but it was perfect.

    I have no deactivated test plugin and reactivated 1.8.1. again.

    By the way, I did this 3 times just in case.

  12. Zdev1
    Member
    Posted 1 year ago #

    TYPO - "I have no deactivated test plugin" needs to read I have NOW deactivated test plugin. Sorry about that. :)

    I'm excited now to see what you make of this!

  13. Robin W
    Member
    Plugin Author

    Posted 1 year ago #

    Brilliant, thanks for your help. That has eliminated half the changes I made, now I just need to go through the other changes and do the same process. ie change 1/2 back and get you to test again. I'll see which I fancy may be causing the issue - I'll come back shortly !

    Thanks again !

  14. Robin W
    Member
    Plugin Author

    Posted 1 year ago #

    ok, I've created another test version, so can you delete the current test version plugin and then exactly as before (except its now called test2) :

    1. Go to the following site and download and save the test version to your PC, making a note of which directory you save it in.
    http://www.rewweb.co.uk/private-groups-plugin-test-version
    2. Go into your website and go into
    a. Dashboard>plugins>add new plugin>upload and browse to the file you just saved
    b. Click install now, BUT DO NOT CLICK ‘ACTIVATE’ AFTER THIS STEP
    c. Click ‘return to plugins page’
    d. You will see that you now have the original ‘bbp private groups’ plugin and a new ‘bbp private groups test2’
    e. Deactivate the original ‘bbp private groups’
    f. Activate the new ‘bbp private groups test2’
    3. Then test to see if this works without error
    4. Then deactivate the ‘bbp private groups test2’ and activate the ‘bbp private groups’ so that you have a working site again.

    Again, please let me know the result, and thanks again for helping !!

  15. Zdev1
    Member
    Posted 1 year ago #

    Done, and got this error. I think it's exactly as the one I was getting:

    Warning: array_merge(): Argument #2 is not an array in /home/content/p3nexnas05_data01/83/2102083/html/wp-content/plugins/bbpress/includes/common/functions.php on line 1344

  16. Zdev1
    Member
    Posted 1 year ago #

    Keep in mind, the only thing I'm not seeing is the main forum landing page. I can click on any forum, post or entry following the Recent Posts and Recent Replies links in the sidebar, but can't get to them from landing page.

  17. Robin W
    Member
    Plugin Author

    Posted 1 year ago #

    Great , thanks for that, the news either way is good, as it lets me narrow the search.

    I'll come back with another version.

  18. Robin W
    Member
    Plugin Author

    Posted 1 year ago #

    Zdev1 - can you let me know

    version of wordpress
    version of bbpress
    theme name
    what other plugins you are running

  19. Zdev1
    Member
    Posted 1 year ago #

    WP - Version 3.9.1
    bbPress - Version 2.5.4
    bbP private groups - Version 1.8
    bbP topic count - Version 1.3.1
    Better bbPress Signature - Version 1.1.0
    Jetpack by WordPress.com - Version 3.0.2
    Rating-Widget: Star Rating System - Version 2.1.1
    WooCommerce - Version 2.1.12

    Theme Name is Total

  20. Robin W
    Member
    Plugin Author

    Posted 1 year ago #

    great thanks for that information

    can you try another version for me - this is again a test to see whereabouts the error lies. If it works I am much closer !

    same procedure as before, so can you delete the current test version plugin and then exactly as before (except its now called test3) :

    1. Go to the following site and download and save the test version to your PC, making a note of which directory you save it in.
    http://www.rewweb.co.uk/private-groups-plugin-test-version
    2. Go into your website and go into
    a. Dashboard>plugins>add new plugin>upload and browse to the file you just saved
    b. Click install now, BUT DO NOT CLICK ‘ACTIVATE’ AFTER THIS STEP
    c. Click ‘return to plugins page’
    d. You will see that you now have the original ‘bbp private groups’ plugin and a new ‘bbp private groups test3’
    e. Deactivate the original ‘bbp private groups’
    f. Activate the new ‘bbp private groups test3’
    3. Then test to see if this works without error
    4. Then deactivate the ‘bbp private groups test3’ and activate the ‘bbp private groups’ so that you have a working site again.

    Again, please let me know the result, and thanks again for helping !!

  21. Zdev1
    Member
    Posted 1 year ago #

    Same error:

    Warning: array_merge(): Argument #2 is not an array in /home/content/p3nexnas05_data01/83/2102083/html/wp-content/plugins/bbpress/includes/common/functions.php on line 1344

  22. Robin W
    Member
    Plugin Author

    Posted 1 year ago #

    ok thanks, and interesting.

    will look at again.

    I really do appreciate your help

  23. Zdev1
    Member
    Posted 1 year ago #

    You're welcome. :)

  24. Robin W
    Member
    Plugin Author

    Posted 1 year ago #

    Your continued help with this is appreciated.

    I have spent several hours pouring through code, and I am now convinced that it is a very simple error, but tracking it down when I cannot replicate the issue is very annoying.

    I have however found one candidate and would like to try yet another version.

    can you follow instructions as before, but now we're test4

    Let me know what happens - and thanks again.

  25. Robin W
    Member
    Plugin Author

    Posted 1 year ago #

    Zdev1 - Thanks to your substantial help, I have been working hard to define the issue, and have now identified it, and can now reproduce it on my website !

    Zdev1 and pooyasas

    I have fixed it, and posted the new version to my website

    I have posted the new version in

    http://www.rewweb.co.uk/bbp-private-groups/

    I will post this to the wordpress plugins page in the next few days.

    Robin

  26. Robin W
    Member
    Plugin Author

    Posted 1 year ago #

    version 1.9.2 now loaded to wordpress - marking this topic as closed. please start a fresh topic if further help needed.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Private groups
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.