Support » Plugin: WooCommerce Dropbox » Problem with allowed file type

  • Resolved kireaki

    (@kireaki)


    http://prntscr.com/7cje6b

    Hi,

    I don’t know does anyone have this problem, but it’s started today, i can’t add anything from dropbox it gives me this error
    The downloadable file OFFLINE%20COUNTER%20STRIKE.zip?dl=1 cannot be used as it does not have an allowed file type. Allowed types include: jpg|jpeg|jpe, gif, png, bmp, tiff|tif, ico, asf|asx, wmv, wmx, wm, avi, divx, flv, mov|qt, mpeg|mpg|mpe, mp4|m4v, ogv, webm, mkv, 3gp|3gpp, 3g2|3gp2, txt|asc|c|cc|h|srt, csv, tsv, ics, rtx, css, htm|html, vtt, dfxp, mp3|m4a|m4b, ra|ram, wav, ogg|oga, mid|midi, wma, wax, mka, rtf, js, pdf, class, tar, zip, gz|gzip, rar, 7z, psd, xcf, doc, pot|pps|ppt, wri, xla|xls|xlt|xlw, mdb, mpp, docx, docm, dotx, dotm, xlsx, xlsm, xlsb, xltx, xltm, xlam, pptx, pptm, ppsx, ppsm, potx, potm, ppam, sldx, sldm, onetoc|onetoc2|onetmp|onepkg, oxps, xps, odt, odp, ods, odg, odc, odb, odf, wp|wpd, key, numbers, pages

    It happens with anything i try to upload from dropbox i think the problem is that it shows as .zip?dl=1 not as .zip i can add stuff direct from media in wordpress but i use dropbox for uploading stuff cause they are bigger

    Maybe this is not plugin problem but i’ll post anyway maybe someone know how to fix this

    https://wordpress.org/plugins/woocommerce-dropbox/

Viewing 5 replies - 16 through 20 (of 20 total)
  • Plugin Author Vadiem Janssens

    (@vadiemjanssens)

    Hi guys, great to hear WooCommerce has fixed this issue.
    Update WooCommerce and everything should be fine.

    Using wooCommerce 2.3.11. The issue still exists as I cannot publish my *.zip files:

    The downloadable file [name].zip cannot be used as it does not have an allowed file type. Allowed types include: jpg|jpeg|jpe, png, gif, mov|qt, avi, mpeg|mpg|mpe, 3gp|3gpp, 3g2|3gp2, mid|midi, pdf, doc, docx, docm, pot|pps|ppt, pptx, pptm, odt, ppsx, ppsm, xla|xls|xlt|xlw, xlsx, xlsm, xlsb, key, mp3|m4a|m4b, ogg|oga, wma, wav, mp4|m4v, webm, ogv, wmv, flv

    If anyone like me is struggling to get this done, you have to manually add your mime type to the allowed mime types array.

    add_filter('mime_types', 'my_mimes');
    
    function my_mimes($mimes) {
        // add your mime types
        $mimes['zip'] = 'application/zip';
        return $mimes;
    }

    I have been waiting through several updates of Woocommerce, probably back to 2.3, for this issue to resolve itself. It still hasn’t. I’ve tried several suggestions i have found on the forums and none of them has worked.

    I get a similar error message to kireaki, except I’m not using dropbox. When I try to save the product with the file link to a mobi or epub, I get the error message and the link itself disappears as unacceptable. The buyer, of course, doesn’t get a download link upon purchase. t can, however, put a PDF link in there. I don’t get an error message and the buyer gets a download link.

    I have the latest woo commerce upgrade and it didn’t help me with this problem either.

    What file do I need to add that mimes coding to? I’m not sure. Any other suggestions are most welcome.

    Thank you. I eagerly look forward to getting this resolved.

    Same issuee here 🙁

Viewing 5 replies - 16 through 20 (of 20 total)
  • The topic ‘Problem with allowed file type’ is closed to new replies.