Support » Alpha/Beta/RC » problem with a subdomain multisite install

  • Resolved Ovidiu


    I upgraded a 2.9.2 install to this beta and enabled the multisite configuration. On the network page I am given these configurations to insert into my files:

    define( ‘MULTISITE’, true );
    define( ‘SUBDOMAIN_INSTALL’, false );
    $base = ‘/’;
    define( ‘DOMAIN_CURRENT_SITE’, ‘’ );
    define( ‘PATH_CURRENT_SITE’, ‘/’ );
    define( ‘SITE_ID_CURRENT_SITE’, 1 );
    define( ‘BLOG_ID_CURRENT_SITE’, 1 );

    into wp-config.php


    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    into .htaccess

    If I do this, I get an Error establishing database connection ??? if I then try to access this site.

    If I change the wp-config code to a SUBDOMAIN isntall, liuke this:

    define( ‘SUBDOMAIN_INSTALL’, true );

    Then I get told by my browser, that Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    Can anyone supply me with the right settigns for setting this up for subdomains?

Viewing 15 replies - 1 through 15 (of 17 total)
  • I have a 3.0beta multi site installed into the root of a domain and have both subdomain and some true domain sites mapped and it works.

    My .htaccess is:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    and my other multi-site code from wp-config.php to correspond with the code you posted is

    define( 'MULTISITE', true );
    define( 'VHOST', 'yes' );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', '' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    I don’t have a clue what your problems is, but maybe something in the above will help you figure it out.

    I tried using your config (adapting to my domain) but with the same errors 🙁

    thx for the help though…

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Where in your config file did you put that, Ovidiu? It should be ABOVE the line that says ‘Not below here!’ or something to that effect.


    The problem is this is a blog I copied over from its original location, to test and make it 3.0 ready, but I simply can’t select/enable subdomain option 🙁

    Obviously all the wp-config and DB options have been changed… Don’t know what else I could have overlooked 🙁

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    You say obviously but a lot of people miss that 🙂 Or put it outside the </PHP calls.

    Does the site work WITHOUT the multisite settings?

    😉 sorry, was just too frustrated, I was out of line with that comment.

    Its not the first site I move to 3.0 and all of them are on the same server, so I can’t see the reason why this one fails.

    yeah, the site works fine without multisite.
    If I enable multisite, the network configuration page looks like this:

    I don’t even get asked if I want subdomain type or not. And obviously since my last try, now it says an existing network was found…

    its currently running without multisite u can access it here: that is just a testing URL for now…

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    No worries. Frustration hits us all.

    I noticed at the top that it says an existing wordpress network was detected which is odd. I’m not sure what causes that to get picked up, but I’d go over my config file to make sure I don’t have duplicates somewhere.

    that is from my first try: it created the wpmu tables, aka _sitemeta, etc. then crapped out. now it sees them and says: existing network detected 🙁

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    I wonder if you have to remove the sitemeta stuff to try again. It could be conflicting somehow.

    well, I’ll go google for the Db tables that multisite adds. then I can remove them all…

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    You should be able to compare it to the live-site you copied from. Or… You could whack it and re-copy the DB over. 🙂

    re-importing the Db right now. will post here with new findings :-9

    ok, reimported the DB, updated plugins,themes,wp,etc.

    now before I go to tools and activate the multisite, can anyone explain this???? I can’t change the blog url !? see screen shot:

    oh, and the imported blog had the REDIRECTION plugin active, which might explain my trouble 🙁

    seems to have worked, but can anyone explain the logic behind what wordpress was telling me when enabling multisite:

    Sub-domain Install Because your install is over 1 month old, the sites in your WordPress network must use sub-domains.

    all is good now 🙂 got it working.

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    That’s a recent change Ovi – because remember how in a sibdir install the /blog/ is added to the permalinks? If you don’t know this, all your links get hosed on older installs. So they did a check to disable it.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘problem with a subdomain multisite install’ is closed to new replies.