Support » Plugin: Yoast SEO » Problem with 7.0.2

  • Resolved MartinCap

    (@martincap)


    After upgrading to Yoast SEO 7.0.2 our site slowed down significantly.

    There was roughly a 75% increase in page-generation times in our PHP logs, and something just felt wrong with the speed of the whole site.

    There was nothing in particular in the error logs.

    I have downgraded to 6.3.1 and everything is speedy again.

Viewing 15 replies - 1 through 15 (of 17 total)
  • I posted about this too, it’s a huge impact. Very surprised such a marquee plugin has an issue like this.

    This happened with the 6.0 upgrade and we had to wait for several updates before updating as it originally slowed our site way down and we have a robust dedicated server!

    Thread Starter MartinCap

    (@martincap)

    @noahkuhn @gooma2

    Thanks for confirming it’s not just an issue for us.

    We’ve got a state-of-the-art server set-up, so anything that slows things down is a pretty big issue.

    Moving back to 6.3.1 has rectified the issue completely.

    It seems there are some major flaws in the 7.x updates. It’s disappointing. We’ll definitely be holding off and waiting before updating Yoast plugins in the future.

    • This reply was modified 3 years, 10 months ago by MartinCap.

    WPSEO_Options_Backfill::extend_wpseo this was added in 7.0.2 version is causing this

    I had the same – went back to v6 and it was fast again – and v7 breaks ajax calls too, preventing saving posts.

    Hi

    I had the same issue since v7. My site was slow and when I was trying to publish a post (or edit) It took some seconds to load or had database error.
    I thought my server was the problem until I see this post.

    I went back to version 6.3.1.

    EDIT: I tried older versions, v6.3.1 and v6. They’re causing issues too. I’ve deactivated the plugin.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We apologize for any inconvenience. In order to better assist you, we’ll need more information.

    • Does this issue occur while using the WordPress v4.9.4 (latest)?
    • Does the issue occur while all the non-Yoast plugins are disabled?
    • Does the issue occur while the default 2017 theme is active?
    • Is there any specific posts or pages where the issue occurs? Or does it occur on all over the site (backend, frontend)?
    • If you create a staging site on your localhost by copying the production site, does this resolve the slowness issue?

    We look forward to hearing from you.

    Thread Starter MartinCap

    (@martincap)

    Thanks for your reply @mazedulislamkhan. Here are the answers to your questions:

    Does this issue occur while using the WordPress v4.9.4 (latest)?
    Yes.

    Does the issue occur while all the non-Yoast plugins are disabled?
    Yes.

    Does the issue occur while the default 2017 theme is active?
    Untested.

    Is there any specific posts or pages where the issue occurs? Or does it occur on all over the site (backend, frontend)?
    All over the site. Slow page generations times were shown in our cache performance log. They were typically 50-70% higher than normal.

    If you create a staging site on your localhost by copying the production site, does this resolve the slowness issue?
    I do not have the capabilities to do this.

    It seems many other people are experiencing similar problems.

    For me, downgrading to 6.3.1 stopped the issues completely.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    While we are not sure why you’re experiencing the slowness issue in the Yoast SEO v7.0.2, we do know that there are some bug reports open currently in our GitHub repository regarding the slowness issue. If you to go to our GitHub repository and search for the slowness issue, can you please confirm if you find one that matches to yours?

    Thread Starter MartinCap

    (@martincap)

    I’ve got the same issue for four days. I’ve checked, there isn’t compatibility problem with another plugin and i’ve disabled and re-actived all one by one to find the one which is the issue. It’s definitly Yaost the problem.

    I hope Yoast team will be find a solution because i’ve had to disable the extension for the moment. I’ve got a website with more than 500 pages. I’m afraid for my SEO to have all my settings disabled ^^’

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We apologize for any inconvenience. Since a bug report already opened in our GitHub repository here, we would recommend you to please submit more information in the opened GitHub issue so our development team can investigate this issue further.

    Thread Starter MartinCap

    (@martincap)

    Hi @mazedulislamkhan Thanks for the updates.

    Could you please let us know when this issue is solved in a future update, as we will not updated the plugin until then.

    Many thanks.

    Plugin Support devnihil

    (@devnihil)

    @martincap @ervael There is currently a fix in a beta version for this issue available for download here. This fix will be implemented in the 7.1 release of the plugin as well, however that will not be released until the following week.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Problem with 7.0.2’ is closed to new replies.