WordPress.org

Forums

[resolved] Problem with 2.7 (19 posts)

  1. barnyoka
    Member
    Posted 6 years ago #

    In a previous post, titled Another Problem with 2.7, I reported that my blog was not working after upgrade. Nearly 24 hours later, this problem is still not resolved.

    Suspecting outdated StuffIt Expander as the source of the problem, I downloaded the most recent version. Then, I downloaded StuffIt Cleaner. I used the latter to remove all StuffIt files. Everything, including the copies of WP I had downloaded earlier and all aborted attempts at opening it, went into the Trash, which I then emptied.

    I restarted the computer. I repaired disk permissions and restarted the computer again. I downloaded StuffIt Expander again, installed it, and it seems to be working just fine. I also downloaded the WP.zip file again. StuffIt continues to tell me there's something wrong with the WP zip file. One of the suggested causes from the Support page for StuffIt indicates the cause might lie in the compression software used to zip the files.

    Now, something I did not notice yesterday, is the icon on the WP.zip file - a Gzip icon. I searched for Gzip, found the homepage and downloaded the software. It also will not open the WP.zip file, claiming that Classic is no longer available.

    Once again, I am working on a MacBook Pro with Mac OS X 10.5.4.

    What can I do to acquire a full copy of WordPress 2.7 that WILL open on command?

    Thanks in advance for any more guidance anyone can offer.

    Getting desperate - -

    Dena

  2. odp
    Member
    Posted 6 years ago #

    do you get this error:

    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 46080 bytes) in /customers/eudora.dk/eudora.dk/httpd.www/wordpress/wp-admin/admin-header.php on line 130

  3. barnyoka
    Member
    Posted 6 years ago #

    No.

  4. barnyoka
    Member
    Posted 6 years ago #

    What I get from StuffIt is

    "An error occurred attempting to expand /Users/Home/Desktop/wordpress-2.7.zip

    The archive may be damaged (Error #17537)"

    StuffIt's Support page says this error is "The archive format is corrupt."

  5. barnyoka
    Member
    Posted 6 years ago #

    ODP - I didn't have a problem doing the upgrade. I had a problem getting the 2.7 downloaded zip file to open correctly. I didn't realize I didn't have ALL of the files I needed to use for the upgrade, so what I have effectively accomplished is a partial upgrade, just sufficient to lock me out.

    Thanks for your help.

    Dena

  6. barnyoka
    Member
    Posted 6 years ago #

    The error message I get on my blog is

    "Warning: main(../wp-load.php): failed to open stream: No such file or directory in /hsphere/local/home/baringo1/denacrain.com/blog/wp-admin/admin.php on line 19

    Fatal error: main(): Failed opening required '../wp-load.php' (include_path='.:/usr/local/lib/php:/usr/local/lib/php/PEAR:/usr/local/share/pear') in /hsphere/local/home/baringo1/denacrain.com/blog/wp-admin/admin.php on line 19"

    The blog is looking for wp-load.php, and it's not there. It was either not included in the WP 2.7 zip download file, or else when StuffIt tries to open the download file, it fails to open.

    Sorry these messages are coming in little bits and pieces. It's just that I'm still trying to figure out what's wrong myself.

  7. MichaelH
    Member
    Posted 6 years ago #

    Get 7-zip. Download the zip file from the Download tab at the top of this page. Unzip the file on your local PC, then redo Steps 7 and 8 of Upgrading WordPress Extended.

  8. barnyoka
    Member
    Posted 6 years ago #

    HI, Michael - thanks for this help. However, I went to the pZip link where I found most downloads were for Windows; I'm on a Mac.

    I downloaded p7zip. There was an exe file which I opened. It's all code and I don't know what to do with it.

    Then, I downloaded EZz7.zip. That opened as a little program window. I dragged in the WP downloaded zip file, and received the following error message:

    "Last login: Sat Dec 13 12:06:12 on console
    '/Users/Home/Desktop/EZ 7z.zip Folder/EZ 7z.app/Contents/Resources/7za' x '/Users/Home/Desktop/wordpress-2.7.zip' -o'/Users/Home/Documents/'
    dena:~ Home$ '/Users/Home/Desktop/EZ 7z.zip Folder/EZ 7z.app/Contents/Resources/7za' x '/Users/Home/Desktop/wordpress-2.7.zip' -o'/Users/Home/Documents/'

    7-Zip (A) 4.58 beta Copyright (c) 1999-2008 Igor Pavlov 2008-05-05
    p7zip Version 4.58 (locale=utf8,Utf16=on,HugeFiles=on,2 CPUs)

    Processing archive: /Users/Home/Desktop/wordpress-2.7.zip

    Error: Can not open file as archive

    dena:~ Home$ "

    Then I went to 7zX, and it reported the same error message - cannot open file as archive.

    Can you be any more specific about which 7-zip file I should use?

  9. MichaelH
    Member
    Posted 6 years ago #

    If you have a Windows PC the first one on that list at http://www.7-zip.org/download.html should work.

  10. RoseCitySister
    Member
    Posted 6 years ago #

    That would be great, but as he says, he's on a Mac.

    Why not use the tar.gz version?

  11. MichaelH
    Member
    Posted 6 years ago #

    Oops, sorry, missed the Mac thing so try one of the other 'unofficial' versions.

  12. barnyoka
    Member
    Posted 6 years ago #

    Been there, done that - nothing's working!

    Btw - he is a she!

  13. barnyoka
    Member
    Posted 6 years ago #

    PS> Tried BOTH versions; neither works!

  14. mrmist
    Forum Janitor
    Posted 6 years ago #

    Can you get a Mac ungzip / untar program and use the tar.gz archive?

  15. Christopher Anderton
    Member
    Posted 6 years ago #

    Why do you use Stuffit when there is a excellent UnZip function built into MacOS X?

    Download the file. Right click on the file. Open using "Archive Utility". Done.

  16. RoseCitySister
    Member
    Posted 6 years ago #

    What Anderton said.

  17. barnyoka
    Member
    Posted 6 years ago #

    The message I get with the Archive Utility is

    "Unable to unarchive "wordpress-2.7.zip into "Desktop'.
    (Error 1 - Operation not permitted.)"

    Then I tried downloading it in a way that would expand it as it came in and selected the Mac OS to expand it. That did not work either. Error message:

    "Download Error

    /Users/Home/Desktop/wordpress-2.7.tar.gz could not be opened, beacuse an unknown error occurred.

    Try saving to disk first and then opening the file."

    That brings me back full circle.

    Again - could there be something malicious on my computer that is preventing me from updating my blog?

    Now - here's something interesting!

    The attempted expansion on delivery resulted in two files -

    VYaDOqXG.gz.part
    VYaDOqXG.gz.1.part

    The first one opened just fine. It seems to have all the files I need, as I see wp-load.php among others I have not previously seen. I'm going to try uploading those files now and see what happens. I'll get back to you soon.

    Anyway, what this tells us is that a) my Archive Utility works, b) there IS something wrong with the download file, and c) the error lies in VYaDOqXG.gz.1.part.

    Back soon . . .

  18. barnyoka
    Member
    Posted 6 years ago #

    OK - problem solved - I'm back in business!

    Interesting - I tried to open VYaDOqXG.gz.1.part with StuffIt. It seemed to be taking a very long time to open, so I stopped StuffIt. VYaDOqXG.gz.1.part disappeared from my desktop!

    I don't know what all this means, other than that anyone using a Mac should download to open, not to save, and should have Mac OS do the opening.

    Many thanks to all of you who tried to help. This one has been a struggle, but I think it's been worth it. The new interface looks positively brilliant, and I can't wait to learn my way around it. Well done, everyone!!!

    Dena

  19. elitastic
    Member
    Posted 6 years ago #

    I am not sure if this will help anyone using a mac but it was very quick and easy for me when I did the following:

    In your web browser input http://www.yourdomainname.com/cpanel
    This will take you to your hosting account where you host your blog (you will need the username and password from them)

    In the cpanel/back office of your blog scroll down the page and click the icon which installed your blog initially (my host is HostGator.com and my icon is Fantastico DeLux)

    It is here where the option to upgrade to 2.7 was 30 seconds maximum and no glitches whatsoever.

    I sure do hope this helped.

Topic Closed

This topic has been closed to new replies.

About this Topic