Support » Plugin: EWWW Image Optimizer » Problem whit the optipng

  • Resolved tokar86a

    (@tokar86a)


    I dont seams that i can install this. Or i do something wrong. should be nice if some one cold help me so i can get this right.

    I get this error:

    EWWW Image Optimizer couldn’t install optipng and gifsicle in /storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/. Please adjust permissions or create the folder. If you have installed the tools elsewhere on your system, check the option to ‘Use system paths’.

    But what i can see it is no wrong whit the permission.

    What can be wrong then?

    http://wordpress.org/extend/plugins/ewww-image-optimizer/

Viewing 15 replies - 16 through 30 (of 46 total)
  • Plugin Author nosilver4u

    (@nosilver4u)

    Ok, so that solves mystery #1. You are still getting the warning message, because the plugin compares the 2 sizes. If they are different, it attempts to copy the bundled version to the wp-content/ewww folder. You must have moved the optipng binary, instead of copying it.
    To make that warning go away, copy (not move) the optipng file from /storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/optipng over to /storage/content/69/100069/myabdllife.com/public_html/wp-content/plugins/ewww-image-optimizer/optipng

    It still remains a mystery as to why you can run the gifsicle binary, but not the optipng binary, when they should have been compiled on the same machine. I’m going to double-check how I compiled them, and see if I can find any differences.

    This is the thing i get now from that file you have told me to try some time:

    990020
    987932

    And i still get this error:

    optipng: MISSING Copy binary from /storage/content/69/100069/myabdllife.com/public_html/wp-content/plugins/ewww-image-optimizer/ to /storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/ or Download optipng source

    EWWW Image Optimizer requires jpegtran, optipng or pngout, and gifsicle. You are missing: optipng. Please install via the Settings Page. If the one-click install links don’t work for you, try the Installation Instructions.

    Some more that i should do now?

    Plugin Author nosilver4u

    (@nosilver4u)

    Ok, my suspicion is that perhaps the optipng binaries got corrupted from being transferred in ascii mode instead of binary mode. Delete the EWWW Image Optimizer plugin, delete the optipng binary/file from wp-content/ewww/, and install the plugin again from within wordpress.

    So what should i do now then?

    It still say: optipng: MISSING Copy binary from /storage/content/69/100069/myabdllife.com/public_html/wp-content/plugins/ewww-image-optimizer/ to /storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/ or Download optipng source

    Plugin Author nosilver4u

    (@nosilver4u)

    Ok, you must be very careful with this part. I’m assuming you’re using some sort of FTP client to upload and download files. At any rate, make sure you switch the connection to binary mode. Download the file ‘optipng’ from the first folder listed to your computer. Then upload the file ‘optipng’ back into the second folder.

    Then, change the ewww.php file to this, and see what happens:

    <?php
    echo filesize ('/storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/optipng');
    echo "<br />";
    echo md5_file ('/storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/optipng');
    echo "<br />";
    echo shell_exec ('file /storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/optipng');
    echo "<br />";
    echo filesize ('/storage/content/69/100069/myabdllife.com/public_html/wp-content/plugins/ewww-image-optimizer/optipng');
    echo "<br />";
    echo md5_file ('/storage/content/69/100069/myabdllife.com/public_html/wp-content/plugins/ewww-image-optimizer/optipng');
    echo "<br />";
    echo shell_exec ('file /storage/content/69/100069/myabdllife.com/public_html/wp-content/plugins/ewww-image-optimizer/optipng');
    ?>

    What do you mean whit binary mode?

    I already have optipng in this foler ewww

    Plugin Author nosilver4u

    (@nosilver4u)

    Well, try the php code first, then we’ll worry about binary mode if we need to.

    It say this:

    990020
    5a0f4e8159bbb9b57948529ed5618795
    /storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/optipng: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.24, statically linked, for GNU/Linux 2.6.24, not stripped
    990020
    5a0f4e8159bbb9b57948529ed5618795
    /storage/content/69/100069/myabdllife.com/public_html/wp-content/plugins/ewww-image-optimizer/optipng: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.24, statically linked, for GNU/Linux 2.6.24, not stripped

    Plugin Author nosilver4u

    (@nosilver4u)

    Ok, that all looks good, what does the plugin status section say now? Please click the debug link and include that info too.

    jpegtran: OK version: Independent JPEG Group’s JPEGTRAN, version 9 13-Jan-2013
    optipng: MISSING Copy binary from /storage/content/69/100069/myabdllife.com/public_html/wp-content/plugins/ewww-image-optimizer/ to /storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/ or Download optipng source
    gifsicle: OK version: LCDF Gifsicle 1.68
    GD: OK   Imagemagick ‘convert’: OK
    safe mode: Off  exec(): OK  shell_exec(): OK  finfo: OK  getimagesize(): OK  mime_content_type(): OK
    Operating System: Linux

    jpegtran path: /storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/jpegtran
    optipng path:
    gifsicle path: /storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/gifsicle
    pngout path:
    disabled functions: mysql_pconnect
    gifsicle permissions: 0755
    optipng permissions: 0755
    wp-content/ewww permissions: 2777
    user: 100069

    Plugin Author nosilver4u

    (@nosilver4u)

    I went and looked closer at my binaries, and it appears I compiled gifsicle with a kernel identical to yours, but optipng was compiled on my local dev box that has a newer kernel. I’ll have to find a machine running an older kernel and compile optipng on there. So, the end is in sight.

    So is it any thing more i can do? Maybe talk to the host company?

    Witch has an old version?

    Plugin Author nosilver4u

    (@nosilver4u)

    they might consider upgrading the kernel, but I doubt it. It appears you are running RHEL5, and they would probably have to upgrade it to RHEL6, which is a pretty major deal. I’m going to setup a virtual machine with CentOS 5 (the free version of RHEL) and compile it on there.

    So, just sit tight, and I’ll let you know when it is ready for you to download.

Viewing 15 replies - 16 through 30 (of 46 total)
  • The topic ‘Problem whit the optipng’ is closed to new replies.