Support » Plugin: EWWW Image Optimizer » Problem whit the optipng

  • Resolved tokar86a

    (@tokar86a)


    I dont seams that i can install this. Or i do something wrong. should be nice if some one cold help me so i can get this right.

    I get this error:

    EWWW Image Optimizer couldn’t install optipng and gifsicle in /storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/. Please adjust permissions or create the folder. If you have installed the tools elsewhere on your system, check the option to ‘Use system paths’.

    But what i can see it is no wrong whit the permission.

    What can be wrong then?

    http://wordpress.org/extend/plugins/ewww-image-optimizer/

Viewing 15 replies - 1 through 15 (of 46 total)
  • Plugin Author nosilver4u

    (@nosilver4u)

    If you are using the latest version (1.3.6), click the Debug link at the top of the settings page, and copy and paste the entire plugin status and debug info block here.

    Here you have it:

    Debug Info

    jpegtran path: /storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/jpegtran
    optipng path:
    gifsicle path: /storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/gifsicle
    pngout path:
    disabled functions: mysql_pconnect
    gifsicle permissions: 0755
    optipng permissions: 0755
    wp-content/ewww permissions: 0777
    user: 100069

    Plugin Author nosilver4u

    (@nosilver4u)

    Can you also paste the plugin status section too?

    Lastly, if you have shell access, please try the following on the command line, and see what it says:

    /storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/optipng -v

    If you don’t have shell access, put the code below in a file named ewww.php, place it in your public_html folder, then browse to http://yourwebsite/ewww.php and see what that says:

    <?php
    echo shell_exec('/storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/optipng -v');
    ?>

    Plugin Status

    If updated versions are available below, you may need to enable write permission on the wp-content/ewww folder to use the automatic installs.
    *Updates are optional, but may contain increased optimization or security patches
    jpegtran: OK version: Independent JPEG Group’s JPEGTRAN, version 9 13-Jan-2013
    optipng: MISSING Copy binary from /storage/content/69/100069/myabdllife.com/public_html/wp-content/plugins/ewww-image-optimizer/ to /storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/ or Download optipng source
    gifsicle: OK version: LCDF Gifsicle 1.68
    GD: OK   Imagemagick ‘convert’: OK
    safe mode: Off  exec(): OK  shell_exec(): OK  finfo: OK  getimagesize(): OK  mime_content_type(): OK
    Operating System: Linux

    I only get a blank white site. No text or any thing.

    No i dont have shell access.

    Plugin Author nosilver4u

    (@nosilver4u)

    Ok, just to make sure that code is right, try this instead:

    <?php
    echo shell_exec('/storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/gifsicle --version');
    ?>

    I get this info: LCDF Gifsicle 1.68 Copyright (C) 1997-2011 Eddie Kohler This is free software; see the source for copying conditions. There is NO warranty, not even for merchantability or fitness for a particular purpose.

    Plugin Author nosilver4u

    (@nosilver4u)

    Don’t know why I didn’t think of this sooner, but it is likely that your system is incompatible with the bundled version of optipng.

    Try this code in ewww.php to see if we can get the error message to be displayed:

    <?php
    echo shell_exec('/storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/optipng -v 2>&1');
    ?>

    I only get a white page now.

    Plugin Author nosilver4u

    (@nosilver4u)

    ok, we’re going to attempt to find out more about your system the hard way then. Please send this info via the Contact Me link at http://www.shanebishop.net (I wouldn’t recommend posting it publicly).

    <?php
    echo shell_exec('cat /etc/*-release 2>&1');
    echo "<br />";
    echo shell_exec('lsb_release -a 2>&1');
    echo "<br />";
    echo shell_exec('uname -a');
    echo "<br />";
    phpinfo();
    ?>

    I have send you the mail. You should have it now.

    Plugin Author nosilver4u

    (@nosilver4u)

    Ok, so I’m not spotting anything wrong there. I wanted to make sure libpng and zlib were installed, and they were. It appears to be red hat linux, so I may need to try and setup a dev box with RHEL or CentOS and do some testing.

    What I do want to try if you’re up for it, is to have you hardcode the path to optipng, and see if it works anyway. To do that, go into the WordPress plugin editor, find the file ewww-image-optimizer.php.
    You need to find a section that looks like this which should be line number 848:

    // get the utility paths
    list ($jpegtran_path, $optipng_path, $gifsicle_path, $pngout_path) = ewww_image_optimizer_path_check();

    If you know anything about php, it is in the function named ewww_image_optimizer
    Anyway, you need to add this line directly BELOW that one:

    $optipng_path = '/storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/optipng';

    Then try optimizing some PNG’s and see what happens (hopefully this is enough to trick the optimizer into working).

    I still get this error: EWWW Image Optimizer couldn’t install optipng and gifsicle in /storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/. Please adjust permissions or create the folder. If you have installed the tools elsewhere on your system, check the option to ‘Use system paths’.

    But it do some thing now but it dont save any thing.

    Plugin Author nosilver4u

    (@nosilver4u)

    Perhaps I’m thinking too hard. You keep getting that error, which seems to indicate that it is copying the file over, but something is failing in that process, and resulting in a corrupted optipng binary.

    From what you said otherwise, we did indeed trick the plugin into attempting to optimize the file, but it returned ‘No savings’ because optipng still isn’t working.

    Can you put this into the ewww.php file and see what it does (you can overwrite everything else):

    <?php
    echo filesize ('/storage/content/69/100069/myabdllife.com/public_html/wp-content/ewww/optipng');
    echo "<br />";
    echo filesize ('/storage/content/69/100069/myabdllife.com/public_html/wp-content/plugins/ewww-image-optimizer/optipng');
    ?>

    I get this error now.

    990020
    Warning: filesize(): stat failed for /storage/content/69/100069/myabdllife.com/public_html/wp-content/plugins/ewww-image-optimizer/optipng in /storage/content/69/100069/myabdllife.com/public_html/ewww.php on line 4

Viewing 15 replies - 1 through 15 (of 46 total)
  • The topic ‘Problem whit the optipng’ is closed to new replies.