Support » Fixing WordPress » Problem while trying to add a new plugin

  • I get the following message while trying to add a new plugin:

    PHP Fatal error: Cannot redeclare plugins_api() (previously declared in E:\home\obsidiana\Web\blog\wp-admin\includes\plugin-install.php:29) in E:\home\obsidiana\Web\blog\wp-admin\includes\plugin-install.php on line 57

    Any idea?

    Thanks in advance

Viewing 12 replies - 1 through 12 (of 12 total)
  • esmi

    (@esmi)

    Forum Moderator

    Try re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    Nah, didn’t work. Erased and replaced everything, except wp-content and the files I had at the main folder that don’t come with the fresh download. The behavior is exactly the same, even if I change my theme. I use the portuguese language version, by the way.

    Hello,

    I am having exactly the same error message.
    I run WP’s latest vers ion.

    Everything worked normally, I managed to install or update new extensions after I updated WP some time ago. And all of a sudden, it’s broken.

    The rest of the panel seems to be working properly, so is the blog.

    Any clue ?

    Thanks

    So far, nothing. I’m pretty sure it’s a bug. I was considering deleting all plugins and testing the inclusion of a new one after that, but I think it’s too risky to do, blindly. So I’ll just wait a little more.

    Ok, got it. Apparently there is a problem with the “Google Analytics Visits” plugin. Deactivated it, and the message disappeared. The problem is that I really like that one.

    Thanks !
    You’re right.
    There’s a pb with the plugin.
    But I suspect something wrong with wordpress as well, I’ve had a few error messages before I installed it.

    Hi,
    I am also getting this error message when I try installing a new plugin:
    Fatal error: Cannot redeclare plugins_api() (previously declared in /home1/continv2/public_html/investigations123/wp-admin/includes/plugin-install.php:29) in /home1/continv2/public_html/investigations123/wp-admin/includes/plugin-install.php on line 57

    I am using WP Version 3.1.1
    Any ideas for sorting out this problem? Thanks.

    Wow, same problem and deactivating the GA Visits fixed it… bizarre. Thanks all!!!!

    Obrigado, Andre.
    I had the “Google Analytics Visits” plugin installed for so many weeks, and never caused any problems… until yesterday!
    Armando

    One can still use the plugin, it just has to be deactivated while adding new plugins, and reactivated afterwards. Hopefully no (other) side effects will take place.

    Same here!

    The problem has started since upgrading the plugin to version 1.1.4.9
    I hope the plugin manager will fix the issue…

    Thanks for bringing this to my notice nivosh, this will be fixed right away (its nothing to do with wordpress its the plugin fault!)

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Problem while trying to add a new plugin’ is closed to new replies.