Support » Plugin: WP Mail SMTP by WPForms - The Most Popular SMTP and Email Log Plugin » Problem when using plugin with Appointments plugin using Gmail

  • Resolved Mole_LR

    (@mole_lr)


    Hi!

    Using Appointments version 2.4.1 and WP Mail SMTP by WPForms plugins latest version and it causes problem with creating appointment – no Thank You pop-up, but email is sent and appointment is created! Submission loading icon spins endlessly! When disable plugin – all good, Thank You message as it was, when enable plugin and use Default setting (not GMail) – also all is good…

    Using CloudFlare, but it’s the same when use CloudFlare in Development mode (so – without caching), using CloudFlare ssl! Using Autoptimise and Fastest cache, but they’re not causing it because it does not work with these plugins switched off (and this plugin works fine in all other websites with both speed optimization plugins)…

    What could be the issue?

    Thank You!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi @mole_lr,

    The issue might be with the Appointments plugin you’re using. When you get a chance could you please check the console if any JS errors are recorded while the submission loading icon spins? Also, let me know if the Appointments plugin you’re using is readily available for test and the steps to reproduce the issue.

    Thanks, and please let me know!

    Thread Starter Mole_LR

    (@mole_lr)

    No js errors…but admin-ajax returns 500 error code (but without any php error)!

    Plugin is available here: https://github.com/wpmudev/appointments

    Hi @mole_lr,

    Thanks for the details. Unfortunately, I could not reproduce any issue while used with this plugin. For troubleshooting the error, please follow this tutorial. To log the PHP errors (if any) you can turn WP_DEBUG to true. In case it helps, here’s more details.

    I hope this helps!

    Thread Starter Mole_LR

    (@mole_lr)

    hmm…even when add such shortcode to display calendar and confirmation fields + confirmation pop-up after successful set appointment:
    [app_monthly_schedule service=”1″ worker=”2″]
    [app_pagination step=”1″ month=”1″]
    [app_confirmation confirm_text=”We have received your appointment. Thanks!”]
    ?

    Hi @mole_lr,

    This seems to be a known issue with the appointment plugin due to the older version of the Google API Services library included. WP Mail SMTP includes the latest version of this library. In this case, when appointment tries to send an email, it loads the library included by WP Mail SMTP and the class/method which it is trying to call doesn’t exist in the latest version. There should be some error recorded. To log the PHP errors, you can turn WP_DEBUG to true in your config.php. In case it helps, here’s more details.

    Thanks!

    Hi @mole_lr – We haven’t heard from you in about a week, so I’m going to go ahead and mark this ticket resolved. If you still have questions, though, please feel welcome to continue the conversation.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Problem when using plugin with Appointments plugin using Gmail’ is closed to new replies.