WordPress.org

Forums

Adminer
[resolved] problem wenn frontend ohne ssl und backend NUR per ssl erreichbar ist (4 posts)

  1. souri
    Member
    Posted 1 year ago #

    adminer verwendet WP_PLUGIN_URL, das wird mittels WP_CONTENT_URL
    definiert, das wiederum greift auf $site_url zurück. und in site-url steht entweder http:// oder https://, aber nicht jeweils das passende.

    unsere seiten sind im frontend ohne ssl und das backend nur MIT ssl erreichbar.

    damit kommt adminer aber nicht ganz klar.
    wir hab site_url auf https:// umgestellt, damit ist es
    für uns "gefixt".

    das geht aber nicht für seiten, deren frontend ohne und das backend mit ssl erreichbar sind. leider nimmt wordpress keine protokoll-relativen urls als site_url (also urls die nur mit // beginnen).

    das is mehr als bugreport denn als supportanfrage gedacht :)

    https://wordpress.org/plugins/adminer/

  2. Frank Bueltge
    Member
    Plugin Author

    Posted 6 months ago #

    Ich müsset dafür einen "Workaround" schreiben, da der Default von WP in der Constante nicht passt. :(

  3. souri
    Member
    Posted 6 months ago #

    hm, hm, hm...
    hast du irgendwelche lösungsansetze im kopf? nur so brainstorming mäßig? vl haben wir ein bisserl zeit über um uns das anzuschauen :)

  4. Frank Bueltge
    Member
    Plugin Author

    Posted 6 months ago #

    Wo treten denn die Fehler auf, die Übergabe der URL ist doch via Backend, als mit ssl?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Adminer
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags