Support » Fixing WordPress » Problem w/ default theme – related to WWW

  • I have an odd problem with my WordPress. I have a theme-switcher plugin installed, and 3 active themes. The problem arises when the default theme is selected (when the link for it is clicked). It just shows a blank page. I have to remove the “www” if is there, OR ADD the “www” if it is not there, for the site to show up again. It’s very odd. I’ve tried taking out the WWW and adding it in my WordPress options. Doesn’t seem to fix the problem either way. I also tried this plugin that enforces either “www” or no “www” according to your wordpress options, but that didn’t help either. Neither did changing my domain settings to either include or exclude the WWW.

    This happens no matter what theme I set as the default. I don’t know what the problem is. The permissions for each theme’s directory are all 755.

    Any help would be very much appreciated!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Do any of your themes contain shockwave flash? I have seem some themes behave like this if your blog URL includes www then the page wont load correctly if you remove www from the url and vice versa.

    Also often the broswer cache is at fault, post your blog URL here it helps to see what you are talking about.

    If it’s a new blog/domain/host, check that the
    DNS maps http://www.x.y to x.y and vice versa,

    Which version of WordPress. There were “differences” induced in later versions that might affect older themes, particularly in the General->Options settings that may be tripping you up if DNS isn’t perfect.

    No, no flash on my site.

    I was running 2.0.2 .. just upgraded to 2.2, thinking maybe that would fix it, but it didn’t.

    ccoupe – it’s not really a new domain, over a year old. But where would I check that about the DNS? I have Dreamhost, went to the DNS settings in my control panel, but don’t see anything about DNS maps…

    Cleared my cache and that isn’t helping either.

    Again, it basically seems to expect the opposite of what I have set in my options — if I have WWW, when I choose the default theme, I get a blank page, and have to take out the WWW to get to the site again. If I don’t have WWW, same thing happens, and I have to add it.

    Not sure if this info is relevant, but my active plugins are Askimet, flickrRSS, Related Posts, WordPress DB back-up, and WP-scrobbler. And I am using this theme switcher –

    Oh, I just noticed that in my WP-Admin, whatever theme I set under Presentation, I get a message saying “The active theme is broken. Reverting to the default theme.” It says this for every theme, even ones that came with WordPress that I haven’t touched.

    Hmm… any idea as to why?

    EDIT: Actually, I was wrong. This only happens when a certain theme is selected – the other two themes display fine when their links are clicked. I was confused because I had named the theme that is giving me problems “WordPress Default”.

    Dreamhost? No wonder I think I’ve been here before. There’s an option in their control panel under manage DNS about mapping x.y and http://www.x.y to be the same (I strongly suggest that’s what you most likely probably want).

    I’ve upgraded one of my blogs from 2.1.3 to 2,2,1 on Dreamhost so I know it can be done but I did it the old school way without their updater and without problems except some of my themes were broken and I couldn’t find that until the DNS was right.

    1. Make sure your http://www.x.y is the same IP# as x.y. Wait until it is.
    2. While waiting, check if the themes have been updated in the last year <b>and</b> all your plugins works with 2.2. I bet many won’t.

    I still can’t find where to go to do that… I go to Manage Domains > DNS … but the only thing that looks relevant is “Non-editable DreamHost DNS records” and there, both the WWW and no-WWW are set to the same IP address.

    I wonder if it’s just something with that theme? It’s the only one I did completely on my own. But I guess that doesn’t make sense because it still works when you add/remove the WWW.

    Maybe I will just reinstall… -_-

    Ok… I have no clue what I did but it works now 🙂 hehe. Thanks for your help.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Problem w/ default theme – related to WWW’ is closed to new replies.