WordPress.org

Support

Support » How-To and Troubleshooting » Problem w/ 2.5.1 and Safari 3.1.1 (post_new.php)

Problem w/ 2.5.1 and Safari 3.1.1 (post_new.php)

  • mroulston
    Member

    @mroulston

    I just upgraded from 2.5 to 2.5.1, and everything seemed ok when I logged into the dashboard, but as soon as I clicked the “Write” like to post a new message, I noticed some problems.

    The most noticeable problem is that the “Save” and “Publish” buttons in the write sidebar blink continuously from a dimmed colour to normal colour. And the other problem is that at the bottom of the Safari window where it says “Loading… completed x of x items”, the second number just keeps climbing while the first number keeps trying to catch up. I waited a while to see if the page would eventually fully load, but after the second number got up to 1500, I killed the window and tried writing my post in Camino (which worked fine).

    I tried clearing my cache in Safari to see if that had anything to do with it, but no joy.

Viewing 15 replies - 1 through 15 (of 22 total)
  • Yeah I updated my blog to 2.5.1 yesterday and it seemed fine. Now when I try to make a new post I have the same ‘blinky’ problem and my media uploader freezes up on me.

    Try clearing the cache and erasing all your WordPress cookies — I think that fixed the problem for me in Safari.

    mroulston
    Member

    @mroulston

    Thanks for the suggestion, Sam. I tried that, but no joy.

    Clear the cache, delete cookies, quit, relaunch?

    I had this problem in both Camino & Safari — Camino worked after clearing the cache but Safari worked only after I cleared the cookies too.

    mroulston
    Member

    @mroulston

    Yep, that’s exactly what I did, and no joy.

    First time I tried it, I just cleared the cookies that were from blog site, but I just went so far as to delete every cookie in Safari (first clear cache, then delete all cookies, then quit and relaunch), just to see if that might help, but no joy.

    What puzzles me is that I installed a fresh version of 2.5.1 on the same server and tested it and it doesn’t do this problem, so my thinking about my main blog is that something got messed up iduring the upgrade process.

    Make sure you replaced the entire wp-admin and wp-includes directories during the upgrade, and you ran wp-admin/upgrade.php?

    You might try posting from a “fresh” web browser (one you’ve never logged into WP with) and see if the problem persists.

    Until the problem’s fixed, you can turn off JavaScript and still do basic post writing & editing.

    I’m having the same problem. I tried the same suggested solutions, and there’s been no change.

    Firefox doesn’t show the same behavior. Just Safari.

    kay9
    Participant

    @kay9

    I’m having the same problem (flashing “save” and “publish” buttons while writing a post, PLUS it is constantly “saving” the draft as I try to enter material, etc.).

    I am using the latest version of FireFox.

    Tried restarting FF, disabling FF add-ons. Still not fixed. It’s really annoying. No other noticeable problems with WP since upgrade from 2.5 to 2.5.1. Just THIS.

    Anyone know what’s causing this, how to fix? Thanks!

    I’d say the draft auto-save is happening maybe a little too frequently but certainly not enough to be a problem…

    I’ve noticed no issue.

    kay9
    Participant

    @kay9

    You’d notice if the “save” and “publish” buttons were constantly flashing while you tried to write a post. 😉

    Hei, guys!
    I am experiencing the same problem, here.
    Here is a brief description of what happens to me:
    . when writing a new post, the buttons “save” and “publish” blinks randomly
    . I had to set my mySQL configuration to accept more connections, because I was having problems of “too many connections” when the script was open in my browser
    . the browser used was Firefox 2.0.0.14

    People
    I have discovered a way to not have the problem.
    For some reason, the lines above of wp-admin\includes\admin.php where deleted on new version:

    if ( !defined( 'AUTOSAVE_INTERVAL' ) )
    	define( 'AUTOSAVE_INTERVAL', 60 );

    I just put it again (and in my case I changed the parameter value to 120s) and now it is working fine.

    kay9
    Participant

    @kay9

    gabrielz,

    Thank you for posting. Your solution seems to have worked for me (so far!). It’s still saving every now and then (but I assume it’s supposed to), but the flashing of the “save” and “publish” buttons seems to have STOPPED! yay~!

    Thanks again!

    Seems to have worked for me, too. Thanks!

    Same issue here, tried everything, no luck.
    Gabrielz solution did the trick for me. Thanks!

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Problem w/ 2.5.1 and Safari 3.1.1 (post_new.php)’ is closed to new replies.