Support » Plugin: Pods Gravity Forms Add-On » Problem Validating a Time Field

  • Resolved cinderalla

    (@cinderalla)


    Hi – I have a time field on my Gravity Form that is mapped to a time field in a Pod custom post type. The time format type is set to 12 hour and the time format is set to 4:32 PM (also tried with 04:32 PM).

    I’ve tried a number of other settings and get this validation error when trying to submit the form with an MM value of 00. For example, 12:00 PM:

    Time was not provided in a recognizable format: “12:0 pm”

    If MM starts with a 0 (e.g. 12:05 PM) always get the error.
    if MM is greater than 9 (e.g. 12:30 PM), the form validates.

    When I turn the Pods Feed off in the Gravity form, the time field validates as expected with a 12:00 PM time.

    Any ideas? Is there a setting I’m missing somewhere?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter cinderalla

    (@cinderalla)

    Also, just found that even though the form validates with a 12:30 PM value, the pod value in the time field is empty.

    I resolved with a text field in Pods, not a date type field… but not work properly because the date format is not localizated.

    I input a spanish dd/mm/yy date, and I receipt a english date in pods yy/mm/dd

    Plugin Author Jim True

    (@jimtrue)

    If you’re still experiencing this issue, you should add this as a bug report for the Gravity Forms plugin. It makes sure we get the proper information collected, including your form template:

    https://github.com/pods-framework/pods-gravity-forms/issues/new

    We can’t work bug reports through the forums.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Problem Validating a Time Field’ is closed to new replies.