Support » Plugin: Quiz And Survey Master - Best Quiz, Exam and Survey Plugin for WordPress » Problem using shortcode in message before quiz text

  • Resolved alsterb

    (@alsterb)


    Hi!

    I found a couple more support items similar to this in this forum, but they had no answers so I thought I would ask myself.

    I’m using your wonderful plugin, but I have an issue when it comes to adding shortcodes to the “Message Displayed Before Quiz” text of a quiz (under the tab “text”).

    The shortcode doesn’t render, but just displays the shortcode text.

    I tried it with WordPress’s default audio shortcode and also using an audio plugin. I also had problems trying to add video. I had to use YouTube iFrame embed instead. The only way I can get audio into the message before a quiz is using something like Soundcloud with iframe embed code, or by having the audio as a link to another window. However, this is less than ideal because often I use just audio snippets of phrases.

    You can see the issue on the page reached using the link included here.

    If this is a paid for add-on, that’s no problem. The plugin is really great, and this is just a niggle that would be great to resolve!

    Thanks, Alex

    • This topic was modified 2 years, 2 months ago by alsterb.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi,

    Right now, “Message before quiz” section doesn’t support audio shortcodes. If you like, I can forward it as the feature request to the development team. Please let me know.

    Regards,
    Kriti

    Hi Alex

    Yes I noticed the short codes do not work and it would be very useful if they did. Great suggestion to use iframe. I didn’t think of that. Thank you.

    I had a look at your quiz and it looks really professional! Especially with the progress bar between the buttons in mobile view. That would solve my button issue as they are on top of each other in a block.

    How did you get the progress bar working? I switched it on and nothing!

    Does it need an extra plugin to activate?

    Thanks for your time.

    Tim

    Thread Starter alsterb

    (@alsterb)

    Hi Tim,

    I started taking a different approach and embedding the quiz into existing pages where there was no problem with shortcodes. This has given me more control, and I set up a custom post type with an area to add the quiz shortcode.

    The only way I could get the progress bar to work is by dividing questions over multiple pages. If I use the option:

    “How many questions per page would you like? (Leave 0 to use pages created on Questions tab)”

    …set to one for example, it doesn’t work. I have to leave this set to 0 and manually divide up the questions.

    I hope this makes sense!

    • This reply was modified 2 years, 1 month ago by alsterb.

    Hi Alex

    Thank you so much for getting back to me! I cant wait to try it out now. I just had it set to 6 pages. Now I’ll break it up as you suggest.

    Thank you again

    Tim

    Hi Alex

    I have it sorted now and its working perfectly. The progress bar separates the stacked buttons in mobile view.

    I would never have spotted how to fix the issue without your suggestion. It has solved both my issues.

    I can’t thank you enough!

    Cheers

    Tim

    Thread Starter alsterb

    (@alsterb)

    You’re welcome! I’m glad you got it sorted!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Problem using shortcode in message before quiz text’ is closed to new replies.