Support » Fixing WordPress » Problem using Japanese language extension

  • Hi all,
    I have been playing with wordpress to use in my site. I have used Japanese language .mo file. I have tested the whole system in my computer (Windows XP, Apache 2, PHP5, MySQL4.1) and the blog runs fine. When I run it from my website (Apache 2, MySQL4.1, PHP4.3) I can see default (English) interface only. I tried to debug the problem by adding some ‘echo’ codes in wp-l10n.php file. In the load_textdomain function I found one different behavor between my local server and website. In my local machine the $l10n[$domain] variable shows ‘Object id #70’ whereas the remotely hosted site shows ‘Object’ only. What setting is causing this difference and is it the reason why the language extension is not functioning properly? Please help me!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Finally I solved this problem! There was a bug in the file ‘gettext.php’ (or in my server). In the original gettext file there are two possible values of $magic=$this->readint() [$MAGIC1 =- 1794895138 and $MAGIC2 = – 569244523]. My local computer shows a value of – 1794895138. However, in my host’s server, the value was 2500072158. I modified the condition as ‘if ($magic == $MAGIC1 || $magic==2500072158)’ and the problem solved! Still puzzled why the server is unique.

    Hi there,

    I’ve been using the Japanese language version for a while and it’s working fine, except for showing the month and date in the posts. What’s weird is that they show up fine in the calendar. Any idea?



Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Problem using Japanese language extension’ is closed to new replies.